Willkommen zu Rapid PHP

  • Funktionen
  • Arbeiten mit Dateien
  • Arbeiten mit Projekten
  • Bearbeiten von HTML und XHTML
  • Bearbeiten von Stylesheets
  • Bearbeiten von PHP-Code
  • Bearbeiten von JavaScript-Code
  • Bearbeiten von Skripts
  • Kaufen
  • Support


Übersicht

Rapid PHP ist ein umfangreicher, flexibler und einfach zu bedienender Editor für Webdokumente (HTML, CSS, JavaScript, PHP und andere).

Sie können sofort mit dem Erstellen von HTML-, XHTML-, CSS-, JavaScript- und PHP-Code beginnen, denn intergrierte Werkzeuge helfen beim Schreiben, Formatieren, Validieren, Navigieren und der Wiederverwendung von Codeteilen.


SOFTWARE-LIZENZVERTRAG

Rapid PHP 2010 Linzenzvertrag

Bevor Sie die Rapid PHP Software benutzen, lesen Sie diese Bestimmungen bitte genau durch. Sie dürfen diese Software nur wie im Rahmen dieser Lizenz beschrieben benutzen.

1. SOFTWARE

Der im folgenden gebrauchte, groß geschriebene Begriff "SOFTWARE" bezieht sich auf Rapid PHP Version 10.0, jegliche Updates der Software, jegliche zusätzlichen Programmresourcen, die Ihnen von Karlis Blumentals zur Verfügung gestellt wurden, das Benutzerhandbuch, jegliche zugehörigen Softwarekomponenten, jegliche in Beziehung stehenden Datenträger und gedruckte Materialien und jegliche "online"- oder elektronische Dokumentation.

2. URHEBERRECHT

Die SOFTWARE ist urheberrechtlich geschützt, 2004-2010, Karlis Blumentals. Die SOFTWARE wird lizenziert, nicht verkauft.

3. TESTVERSION

Sie dürfen die SOFTWARE zu Testzwecken 30 Mal kostenlos nutzen (starten). Sie müssen die Lizenzgebühren bezahlen und Ihre Kopie registrieren, um die SOFTWARE nach Ablauf der Test-Nutzungen (Startvorgänge) weiter zu nutzen. Anderenfalls müssen Sie die SOFTWARE von Ihrem Computer löschen (deinstallieren). Für Informationen über die Bezahlung der Lizenzgebühren und Registrierung Ihrer Kopie der SOFTWARE, sollten Sie "Hilfe|Registrierung" in der Menüleiste anwählen. Während der Testdauer dürfen Sie die SOFTWARE auf so vielen verschiedenen Computern nutzen wie Sie mögen.

4. REGISTRIERTE VERSION

Nach Freischaltung (oder Installation) der registrierten Kopie, dürfen Sie die SOFTWARE auf der Anzahl von Computern nutzen, für die Sie eine separate Lizenzgebühr bezahlt haben, und der Hauptnutzer eines jeden Computers für den Sie eine separate Lizenzgebühr bezahlt haben, darf die SOFTWARE auf seinem tragbaren Computer nutzen. Sie dürfen außerdem eine Kopie der SOFTWARE für Backup- oder Archiv-Zwecke anlegen. Ansonsten dürfen Sie die SOFTWARE nicht, weder als Ganzes noch in Teilen, kopieren. Falls die registrierte Kopie der SOFTWARE auf einem Netzwerkserver oder anderem Massenspeicher installiert ist, müssen Sie eine Lizenz für jeden einzelnen Computer, auf dem die SOFTWARE genutzt wird, erwerben. Eine Lizenz für die SOFTWARE darf nicht durch abwechselnde Nutzung der SOFTWARE auf verschiedenen Computern geteilt werden. Sie dürfen alle Ihre Rechte an der registrierten Version der SOFTWARE im Rahmen dieser Lizenz dauerhaft weitergeben, vorausgesetzt, Sie geben alle Kopien der SOFTWARE weiter und der Empfänger akzeptiert den Software-Lizenzvertrag. Alle Rechte, die nicht ausdrücklich im Rahmen dieser Lizenz gewährt worden sind, liegen bei Karlis Blumentals.

5. HAFTUNGSAUSSCHLUSS

DIESE SOFTWARE WIRD OHNE JEGLICHE GARANTIEN, WEDER SPEZIELLE ODER IMPLIZIERTE, ZUR VERFÜGUNG GESTELLT, DIE UNTER ANDEREM, ABER NICHT DARAUF BESCHRÄNKT, DIE ZUSICHERUNG ALLGEMEINER GEBRAUCHSTAUGLICHKEIT EINSCHLIESSEN. AUF KEINEN FALL IST DER AUTOR FÜR IRGENDWELCHE SCHÄDEN, EINSCHLIESSLICH NEBEN- UND FOLGESCHÄDEN, DIE AUS DER NUTZUNG DER SOFTWARE ENTSTEHEN, VERANTWORTLICH, OB AUF DIE MÖGLICHKEIT EINES SOLCHEN SCHADENS HINGEWIESEN WURDE ODER NICHT. SIE BESTÄTIGEN, DASS SIE DIESE LIZENZ GELESEN UND VERSTANDEN HABEN UND STIMMEN ZU, AN IHRE BEDINGUNGEN GEBUNDEN ZU SEIN.

6. VERBREITUNG

Die SOFTWARE darf in ihrer originalen, unmodifizierten und unregistrierten Form kostenlos verbreitet werden. Diese Verbreitung muss alle Dateien der ursprünglichen Verbreitung beinhalten. Händler dürfen dafür keine Gebühr verlangen.

7. WEITERE BESCHRÄNKUNGEN

Sie dürfen die SOFTWARE in keiner Weise modifizieren, mittels Reverse Engineering zerlegen, dekompilieren oder disassemblieren. Darunter fällt auch die Veränderung oder Entfernung von Nachrichten oder Fenstern. Sie dürfen keinen Teil der SOFTWARE verändern. Karlis Blumentals behält sich die Änderung von jeglichen Teilen der SOFTWARE vor. Sie dürfen die SOFTWARE weder vermieten, noch verpachten oder verleihen.

8. KÜNDIGUNG

Diese Lizenz endet, sobald Sie ihren Geschäftsbedingungen nicht nachkommen. Sobald Ihre Lizenz erlischt, müssen Sie alle Kopien der SOFTWARE, die sie besitzen, zerstören. Das Erlöschen dieser Lizenz schränkt andere Rechte, die Karlis Blumentals per Gesetz zustehen, nicht ein.

Falls Sie irgendwelche Fragen zu diesem Software-Lizenzvertrag haben, schicken Sie bitte eine Mail an: support@blumentals.net

Rapid PHP © 2004-2010 Karlis Blumentals


Rapid PHP 2010 kaufen

Wenn Sie Rapid PHP 2010 nach dem Testzeitraum verwenden wollen, müssen Sie die Software erwerben. Durch den Kauf helfen Sie uns, die Software zu verbessern und weiterzuentwickeln.

Preise

Edition | Preis USD | Preis EUR | Kaufen
Rapid PHP 2010 | $59.85 | € 45.85 | Jetzt kaufen
Rapid PHP 2010 Privatlizenz * | $39.85 | € 29.85 | Jetzt kaufen

* Zur privaten nicht-kommerziellen Verwendung.

  • Für Site- und Akademiker-Lizenzen klicken Sie hier.
  • Für die aktuellen Sonderpreise klicken Sie hier.

Sie können die Software auf folgende Arten kaufen:

  • Online (verschlüsselte, sichere Site)
  • Per Telefon, Fax und Post

Bezahlung und Lieferung

  • Bezahlmethoden sind Kreditkarte, Banktransfer, Scheck und Barzahlung. Für andere Zahlarten kontaktieren Sie bitte sales@blumentals.net
  • Sie können die Vollversion der Software direkt nach der erfolgreichen Bestellung herunterladen.

Hinweis

  • Alle Updates der Version sind kostenlos für registrierte Benutzer.

Verwandte Themen

  • Vollversion aktivieren


Aktivierung der Vollversion

Nachdem Sie das Produkt gekauft haben, erhalten Sie weitere Informationen zum Laden der Vollversion und der Aktivierung.

Hinweis

  • Wenn Sie Probleme oder Fragen haben, dann schreiben Sie uns eine E-Mail: sales@blumentals.net


Bestellung per Telefon

Sie können die folgenden Telefonnummern verwenden.

US und Kanada: +1-800-903-4152 (gebührenfrei)
Europa und International: +49-221-31088-20lt;brgt;

Sie müssen dabei die Produkt-ID 300002722 übermitteln.

Diese Telefonnummer ist nur für Bestellungen. Leider kann das Verkaufsteam keine technische Hilfe oder Informationen zum Produkt anbieten. Den technischen Support finden Sie unter: http://www.blumentals.net/support

Verwandte Themen

  • Vollversion aktivieren


Bestellen per Fax oder Post

Bestellen per Telefon, Fax oder Post

Bestellung per Telefon

Sie können die folgenden Telefonnummern verwenden.

US und Kanada: +1-800-903-4152 (gebührenfrei)
Europa und International: +49-221-31088-20<br>

Sie müssen dabei die folgende Produkt-ID übermitteln.

  • Rapid PHP - 300002722
  • Rapid PHP Privatlizenz - 300009198

Diese Telefonnummer ist nur für Bestellungen. Leider kann das Verkaufsteam keine technische Hilfe oder Informationen zum Produkt anbieten. Den technischen Support finden Sie unter: http://www.blumentals.net/support

Bestellen per Fax oder Post

Bitte drucken Sie das folgende Registrierformular aus:

  • Rapid PHP
  • Rapid PHP Privatlizenz
und faxen oder mailen Sie an:

ShareIt!
element 5 AG
Vogelsanger Str. 78
50823 Köln
Deutschland

Tel: +49-221-31088-20
Fax: +49-221-31088-29
E-Mail: register@shareit.com

US check and cash orders can be sent to US office at:

ShareIt! Inc.
P.O. Box 844
Greensburg, PA 15601, USA
Phone: (724) 850 - 8186
Fax: (724) 850 - 8187

ALL CHECKS SENT TO THE U.S. OFFICE MUST BE MADE PAYABLE TO: "ShareIt!Inc."

Verwandte Themen

  • Vollversion aktivieren


Mit Dateien arbeiten

In Rapid PHP können Sie mit verschiedenen Dateitypen arbeiten - PHP, HTML, XHTML, CSS, JavaScript, WML, ASP, XML und viele andere. Sie können ein neues Dokument von Grund auf neu erstellen oder von einer Vorlage. Sie können eine bestehende Datei nicht nur vom lokalen Datenträger öffnen, sondern auch direkt von einem FTP-Server oder einer Website. Sie können ein Dokument nicht nur auf dem lokalen Datenträger speichern, sondern auch direkt auf einem FTP-Server.

Die folgenden Themen bieten weitere Informationen:

  • Eine neue Datei erstellen
  • Ein HTML-Dokument erstellen
  • Ein CSS erstellen
  • Eine Datei öffnen
  • Eine Datei vom FTP öffnen
  • Eine Datei vom Web öffnen
  • Eine Datei speichern
  • Datei auf FTP speichern
  • Datei auf FTP veröffentlichen (lokal speichern und hochladen)


Eine neue Datei erstellen

Sie können ein neues PHP, HTML, XHTML, CSS, WML, ASP, XML, Perl oder anderes Dokument von Grund auf neu erstellen oder von einer Vorlage.

Um eine leere Datei zu erstellen...

  1. Klichen Sie im Datei-Menü auf Neu.
  2. Klicken Sie auf den Dokumententyp, den Sie erstellen wollen.
  3. Klicken Sie auf OK.

Um eine neue Datei aus einer Vorlage zu erstellen

  1. Klicken Sie im Datei-Menü auf Neu aus Vorlage.
  2. Im Neu aus Vorlage-Dialog können Sie die Vorlage, die Sie für Ihr neues Dokument verwenden wollen, über die Registerkarten auswählen.
  3. Klicken Sie auf OK.

Hinweise

  • Um ein leeres Dokument des Standardtypes (gemäß den Voreinstellungen) zu erstellen, klicken Sie auf Neu [image] in der Symbolleiste.
  • Sie können die Pfeile in der Nähe der Neu [image] -Schaltfläche verwenden, um schnell eine leere Datei des angegebenen Typs zu erstellen.

Verwandte Themen

  • Vorlagen


Ein neues HTML-Dokument zu erstellen

Sie können ein leeres HTML-Dokument erstellen oder eine der vorhandenen Vorlagen verwenden.

Um ein leeres HTML-Dokument zu erstellen...

  1. Klichen Sie im Datei-Menü auf Neu.
  2. Wählen Sie den HTML-Dokumententyp.
  3. Klicken Sie auf OK.

Um ein HTML-Dokument von einer Vorlage zu erstellen...

  1. Klicken Sie im Datei-Menü auf Neu aus Vorlage.
  2. Im Neu aus Vorlage-Fenster klicken Sie auf das HTML-Register und dann auf die Vorlage, die Sie für Ihr HTML-Dokument verwenden wollen.
  3. Klicken Sie auf OK.

Hinweis

  • Wenn Sie PHP-Code zu Ihrem neuen HTML-Dokument hinzufügen wollen, dann müssen Sie ihr HTML-Dokument zuerst als PHP-Script speichern.

Verwandte Themen

  • Vorlagen


Ein neues PHP-Script erstellen

Sie können ein leeres PHP-Script erstellen oder eine der vorhandenen Vorlagen verwenden.

Um ein leeres PHP-Script zu erstellen...

  1. Klichen Sie im Datei-Menü auf Neu.
  2. Wählen Sie PHP aus der Liste.
  3. Klicken Sie auf OK.

Um ein PHP-Dokument von einer Vorlage zu erstellen...

  1. Klicken Sie im Datei-Menü auf Neu aus Vorlage.
  2. Im Neu aus Vorlage-Fenster klicken Sie auf das PHP-Register und dann auf die Vorlage, die Sie für Ihr PHP-Script verwenden wollen.
  3. Klicken Sie auf OK.

Hinweise

  • Wenn der Standarddokumententyp in den Voreinstellungen PHP ist (was er standardmäßig ist), dann brauchen Sie nur auf Neu [image] in der Symbolleiste zu klicken.

Verwandte Themen

  • Vorlagen


Ein neues CSS-Stylesheet erstellen

Sie können ein leeres CSS-Dokument erstellen oder eine der vorhandenen Vorlagen verwenden.

Um ein leeres CSS-Dokument zu erstellen...

  1. Klichen Sie im Datei-Menü auf Neu.
  2. Wählen Sie den CSS-Dokumententyp.
  3. Klicken Sie auf OK.

Um ein CSS-Dokument von einer Vorlage zu erstellen...

  1. Klicken Sie im Datei-Menü auf Neu aus Vorlage.
  2. Im Neu aus Vorlage-Fenster klicken Sie auf das CSS-Register und dann auf die Vorlage, die Sie für Ihr Dokument verwenden wollen.
  3. Klicken Sie auf OK.

Verwandte Themen

  • Vorlagen


Eine Datei öffnen

Um eine Datei zu öffnen...

  1. Klicken Sie im Datei-Menü auf Öffnen.
  2. Suchen Sie die Datei, die Sie öffnen wollen.
  3. Klicken Sie auf Öffnen.

Hinweise

  • Sie können auch auf Öffnen [image] in der Symbolleiste klicken.
  • Um schnell auf die zuletzt verwendeten Dateien zuzugreifen verwenden Sie das Erneut öffnen-Untermenü im Datei-Menü.

Verwandte Themen

  • Eine Datei vom FTP öffnen
  • Eine Datei vom Web öffnen


Eine Datei vom FTP öffnen

Um eine Datei vom FTP-Server zu öffnen...

  1. Klicken Sie im Datei-Menü auf Von FTP öffnen.
  2. In der Sites-Liste des FTP-Browser-Dialogs wählen Sie eine FTP-Site oder klicken auf Neue Site [image] in der Symbolleiste, um eine neue FTP-Site hinzuzufügen.
  3. Wenn die FTP-Site angezeigt wird, klicken Sie auf Verbinden [image] in der Symbolleiste.
  4. Suchen Sie die Datei, die Sie öffnen wollen.
  5. Klicken Sie auf Öffnen.

Hinweis

  • Wenn die Verbindung zur FTP-Site nicht aufgebaut werden kann, stellen Sie sicher, dass Sie die richtigen Daten eingegeben haben und das die Internet-Verbindung verfügbar ist und der FTP-Server läuft.


Eine Datei vom Web öffnen

Um eine Datei vom Webserver zu öffnen...

  1. Klicken Sie im Datei-Menü auf Vom Web öffnen.
  2. Geben Sie die HTTP-Adresse der Datei an, die Sie öffnen wollen.
  3. Klicken Sie auf OK.

Hinweis

  • Wenn die Verbindung zur Website nicht aufgebaut werden kann, dann prüfen Sie bitte, ob Sie die Adresse richtig eingegeben haben.


Datei speichern

Um ein Dokument schnell zu speichern, klicken Sie auf Speichern [image] in der Symbolleiste.

Um eine Kopie einer Datei zu speichern...

  • Klicken Sie im Datei-Menü auf Speichern unter.
  • Im Dateinamen-Feld tragen Sie den neuen Namen für die Datei ein.
  • Klicken Sie auf Speichern.

Hinweis

  • Um alle offenen Dateien auf einmal zu speichern, klicken Sie auf Alle speichern [image] in der Symbolleiste.

Verwandte Themen

  • Datei auf FTP speichern


Datei auf FTP speichern

Um eine Datei, die vom FTP-Server geöffnet wurde, schnell zu speichern, klicken Sie auf Speichern [image] in der Symbolleiste.

Um neue oder lokale Dateien auf den FTP-Server zu speichern...

  1. Klicken Sie im Datei-Menü auf Speichern nach FTP.
  2. In der Sites-Liste des FTP-Browser-Dialogs wählen Sie eine FTP-Site oder klicken auf Neue Site [image] in der Symbolleiste, um eine neue FTP-Site hinzuzufügen.
  3. Wenn die FTP-Site angezeigt wird, klicken Sie auf Verbinden [image] in der Symbolleiste.
  4. Geben Sie im Dateinamen-Dialog den Dateinamen für Ihre Datei an. Geben Sie eine Erweiterung (z.B. .htm) im Dateinamen ein.
  5. Klicken Sie auf Speichern.

Hinweis

  • Wenn die Verbindung zur FTP-Site nicht aufgebaut werden kann, stellen Sie sicher, dass Sie die richtigen Daten eingegeben haben und das die Internet-Verbindung verfügbar ist und der FTP-Server läuft.


Datei auf FTP veröffentlichen

Mit der Veröffentlichen-Funktion speichern Sie Ihre Dateien lokal und laden dann eine Kopie auf den FTP-Server.

Um lokale Dateien auf dem FTP-Server zu veröffentlichen...

  1. Klicken Sie im Datei-Menü auf Auf FTP veröffentlichen.
  2. Wählen Sie im FTP durchsuchen-Dialog in der Sites-Liste eine FTP-Site oder klicken Sie auf Neue Site [image] in der Symbolleiste, um eine neue FTP-Site hinzuzufügen.
  3. Wenn die FTP-Site angezeigt wird, klicken Sie auf Verbinden [image] in der Symbolleiste.
  4. Wählen Sie eine Remote-Datei zum Überschreiben oder geben Sie im Dateinamen-Feld einen Namen für Ihre Datei ein. Stellen Sie sicher, dass der Dateinamen auch die Erweiterung enthält (z.B. index.htm).
  5. Klicken Sie auf Speichern.

Hinweis

  • Wenn die Verbindung zur FTP-Site nicht aufgebaut werden kann, stellen Sie sicher, dass Sie die richtigen Daten eingegeben haben und das die Internet-Verbindung verfügbar ist und der FTP-Server läuft.

Verwandte Themen

  • Verknüpfte Dateien


Verknüpfte Dateien

Der Verknüpfte Dateien-Dialog wird mit dem Auf FTP veröffentlichen-Befehl geöffnet. Er zeigt eine Liste aller Dateien, die mit dem Dokument verknüpft sind (Bilder, Stylesheets, JavaScripts) und erlaubt die Dateien für das Hochladen zum FTP-Server auszuwählen.

Liste der Dateien

Zeigt eine Liste der verknüpften Dateien. Sie wählen die Dateien für das Hochladen durch anhaken der Dateinamen.

Alle markieren

Markiert alle gelisteten Dateien für das Hochladen.

Überspringen

Überspringt das Hochladen der verknüpften Dateien. Nur die aktiven Dokumente werden veröffentlicht.

OK

Bestätigt die markierten Dateien für das Hochladen.


Dateiexplorer

Der Dateiexplorer erlaubt das Durchsuchen von Dateien und Ordnern, ganz wie im Windows Explorer.

Um den Dateiexplorer zu aktivieren, klicken Sie im Ansicht-Menü auf Dateiexplorer.

Der Dateiexplorer bietet drei Modi - Projekt, Ordner und FTP. Sie können die Dateiexplorer-Modi umschalten, indem Sie die Schaltflächen in der Dateiexplorer-Anzeige verwenden.

Die folgenden Themen bieten weitere Informationen:

  • Projekt-Modus zum Durchsuchen von Projektdateien.
  • Ordner-Modus zum Durchsuchen der lokalen Dateien.
  • FTP-Modus zum Durchsuchen von FTP-Sites.


Projekt-Modus

Im Projekt-Modus des Dateiexplorers können Sie die in den Verzeichnissen und Dateien des aktiven Projekts durchsuchen. Sie können das aktive Projekt im Projekt-Menü auswählen.

Mit einem Doppelklick öffnen Sie eine Datei. Die Aktionen Ausschneiden, Kopieren, Löschen und Umbenennen wenden Sie mit dem Kontextmenü auf Dateien an. Die gleichen Aktionen können auf Ordner angewendet werden.

Hinweise

  • Um die Ansicht der Dateien und Ordner zu ändern, klicken Sie auf die Schaltfläche Ansicht [image] in der Dateiexplorer-Leiste.
  • Sie veröffentlichen Projekte auf dem FTP, indem Sie die Schaltfläche Veröffentlichen [image] in der Dateiexplorer-Leiste klicken.

Verwandte Themen

  • Dateiexplorer


Ordner-Modus

Im Ordner-Modus des Dateiexplorers könnne Sie Ihr lokalen Ordner und Dateien durchsuchen.

Mit einem Doppelklick öffnen Sie eine Datei. Die Aktionen Ausschneiden, Kopieren, Löschen und Umbenennen wenden Sie mit dem Kontextmenü auf Dateien an. Die gleichen Aktionen können auf Ordner angewendet werden.

Hinweise

  • Um die Ansicht der Dateien und Ordner zu ändern, klicken Sie auf die Schaltfläche Ansicht [image] in der Dateiexplorer-Leiste.
  • Um die Dateien und Ordner festzulegen, die angezeigt werden, klicken Sie auf Ordneroptionen [image] in der Dateiexplorer-Liste.

Verwandte Themen

  • Dateiexplorer


FTP-Modus

Im FTP-Modus des Dateiexplorers können Sie Dateien und Verzeichnisse des FTP-Servers durchsuchen.

Um eine Verbindung zur FTP-Site aufzubauen, doppelklicken Sie den FTP-Sitenamen in der Siteliste. Wenn sich Ihr FTP-Konto noch nicht in der Liste befinden, müssen Sie es hinzufügen.

Hinweise

  • Um ein neues FTP-Konto hinzuzufügen, klicken Sie auf FTP-Site hinzufügen [image] im der Dateiexplorer-Liste.

Verwandte Themen

  • Dateiexplorer


Arbeiten mit Projekten

Das Projekt-Management macht das Arbeiten mit größeren Dateigruppen einfacher, besonders wenn diese zu unterschiedlichen Websites gehören. Die wichtigesten Vorteile von Projekten sind: einfache Dateihandhabung und schnelles Hochladen auf einen FTP-Server.

Sie erstellen ein Projekt, indem Sie einen Wurzelordner festlegen, der die Dateien und Unterordner enthält und angeben, welche Dateitypen in das Projekt einbezogen werden sollen.

Damit Sie mit den Projekt-Funktionen arbeiten können, muss ein Projekt ausgewählt werden. Sie können zur gleichen Zeit nur ein Projekt auswählen und damit arbeiten.

Die folgenden Themen bieten weitere Informationen:

  • Ein neues Projekt erstellen
  • Ein Projekt auswählen
  • Bestehende Projekte verwalten
  • Projekt auf dem FTP-Server veröffentlichen


Ein neues Projekt erstellen

Sie erstellen ein Projekt, indem Sie einen Wurzelordner festlegen, der die Dateien und Unterordner enthält und angeben, welche Dateitypen in das Projekt einbezogen werden sollen.

Um ein neues Projekt zu erstellen...

  1. Klicken Sie im Projekt-Menü auf Neues Projekt.
  2. Im Feld Projektname geben Sie den Namen des Projekts ein (z.B. MeinProjekt)
  3. Klicken Sie auf Durchsuchen neben dem Feld Wurzelordner, um den Ordner anzugeben, der die Projektdateien und Verzeichnisse enthält.
  4. Geben Sie im Feld Dateitypen die Dateitypen an, die in das Projekt eingeschlossen werden sollen.
  5. Wenn Sie die Funktion zum Hochladen von Dateien verwenden wollen, dann klicken Sie auf Auswählen, um das FTP-Verzeichnis anzugeben.
  6. Klicken Sie auf OK.

Verwandte Themen

  • Ein Projekt auswählen
  • Projekt-Eigenschaften-Dialog


Ein Projekt auswählen

Damit Sie mit den Projekt-Funktionen arbeiten können, muss ein Projekt ausgewählt werden. Sie können zur gleichen Zeit nur ein Projekt auswählen und damit arbeiten.

Um ein Projekt auszuwählen...

  • Klicken Sie im Projekt-Menü auf den Namen des Projekts. Neben dem ausgewählten Projekt im Projekt-Menü erscheint ein Häkchen. Der gewählte Projektnamen wird auch auf der rechten Seite der Statusleiste angezeigt.

Hinweise

  • Sie können auch in der Datei-Explorer-Leiste auf Projekt auf FTP veröffentlichen [image] klicken.
  • Sie können auch einzelne Dateien des Projekts aus dem Datei-Explorer heraus hochladen, indem Sie Zum FTP-Server hochladen im Kontextmenü auswählen.


Bestehende Projekte verwalten

Um die Projekt-Eigenschaften zu bearbeiten...

  1. Klicken Sie im Projekt-Menü auf Projekte verwalten.
  2. Wählen Sie das Projekt aus.
  3. Klicken Sie auf Bearbeiten, um den Projekt-Eigenschaften-Dialog zu öffnen.

Um ein Projekt zu löschen...

  1. Klicken Sie im Projekt-Menü auf Projekte verwalten.
  2. Wählen Sie das Projekt aus.
  3. Klicken Sie auf Löschen

Verwandte Themen

  • Ein neues Projekt erstellen
  • Projekt-Eigenschaften-Dialog


Projekt auf dem FTP-Server veröffentlichen

Wenn Sie bei Ihrem Projekt ein FTP-Verzeichnis angegeben haben, dann können Sie sehr einfach alle oder einzelne Projektdateien auf den FTP-Server hochladen.

Um ein Projekt auf dem FTP-Server zu veröffentlichen...

  1. Stellen Sie sicher, dass das gewünschte Projekt im Projekt-Menü ausgewählt ist.
  2. Klicken Sie im Projekt-Menü auf Projekt auf FTP veröffentlichen.
  3. Markieren Sie die Dateien, die Sie hochladen wollen.
  4. Klicken Sie auf Veröffentlichen.

Hinweise

  • Sie können auch in der Datei-Explorer-Leiste auf Projekt auf FTP veröffentlichen [image] klicken.
  • Sie können auch einzelne Dateien des Projekts aus dem Datei-Explorer heraus hochladen, indem Sie Zum FTP-Server hochladen im Kontextmenü auswählen.

Verwandte Themen

  • Projekt veröffentlichen-Dialog


Projekt-Eigenschaften-Dialog

Der Projekt-Eigenschaften-Dialog erlaubt das Erstellen eines neuen Projekts oder die Bearbeitung der Eigenschaften eines existierenden Projekts.

Projektname

Gibt den Projektnamen an. Empfehlenswert sind kurze und beschreibende Projektnamen.

Beispiel: Meine Website

Wurzelordner

Gibt den Ordner an, der die Projektdateien und Unterordner enthält.

Beispiel: c:\websites\meinesite

Dateityp

Gibt die Dateitypen an, die in das Projekt eingeschlossen werden. Dieses Feld enthält gültige Dateimasken, getrennt durch Semikolon (;).

Beispiel: *.htm;*.txt;*.gif;*.jpg

FTP-Verzeichnis

Gibt das FTP-Verzeichnis für das Projekt an. Klicken Sie auf Auswählen, um ein gültiges FTP-Verzeichnis anzugeben.


Projekt veröffentlichen-Dialog

Der Projekt veröffentlichen-Dialog erblaubt die Auswahl der Projektdateien für das Hochladen auf den FTP-Server.

Liste der Dateien

Zeigt eine Liste der Projektdateien. Sie wählen die Dateien für das Hochladen durch anhaken der Dateinamen.

Filtern nach Updates

Ermöglicht das Filtern der Projektdateien, so dass nur die neu erstellten oder aktualisierten Dateien, innerhalb eines Zeitraums, angezeigt werden.

Alle markieren

Markiert alle Dateien für das Hochladen.

Ausgewählte markieren

Markiert die ausgewählten Dateien für das Hochladen.

Markierung aufheben

Hebt die Markierung aller Dateien auf.

Auswahl merken

Die markierten Dateien sollen gemerkt und automatisch beim nächsten Mal, wenn dieser Dialog geöffnet wird, wieder markiert werden.

Abbrechen

Bricht die Veröffentlichung der Dateien ab und schließt das Fenster.

Veröffentlichen

Lädt die markierten Dateien in das FTP-Verzeichnis des Projekts hoch.


Nach Text suchen

Um nach Text zu suchen...

  1. Klicken Sie im Suchen-Menü auf Suchen.
  2. Geben Sie im Suchen nach-Feld den Text ein, nach dem Sie suchen wollen.
  3. Wählen Sie weitere Optionen, die Sie wünschen.
    Klicken Sie hier, um mehr über die Optionen zu erfahren.
  4. Klicken Sie auf Weitersuchen.

Verwandte Themen

  • Suchen/Ersetzen-Dialog
  • Verwenden der Suchleiste


In Dateien nach Text suchen

Um in Dateien nach Text zu suchen...

  1. Klicken Sie im Suchen-Menü auf In Dateien suchen.
  2. Geben Sie im Suchen in-Feld den Ordern ein, in dem Sie nach Dateien suchen wollen oder klicken Sie auf Durchsuchen, um einen Ordner auszuwählen.
  3. In der Nähe des Suchen in-Feldes können Sie eine Dateimaske eingeben oder auswählen (z.B. *.* oder *.htm).
  4. Geben Sie im Suchen nach-Feld den Text ein, nach dem Sie suchen wollen.
  5. Wählen Sie weitere Optionen, die Sie wünschen.
    Klicken Sie hier, um mehr über die Optionen zu erfahren.
  6. Klicken Sie auf Suchen.

Hinweise

  • Sie können auch auf In Dateien suchen [image] in der Suchen-Leiste.
  • Das Durchsuchen einer großen Anzahl von Dateien kann einige Zeit dauern.

Verwandte Themen

  • In Dateien suchen-Dialog


Text suchen und ersetzen

Um Test zu suchen und zu ersetzen...

  1. Klicken Sie im Suchen-Menü auf Ersetzen.
  2. Geben Sie im Suchen nach-Feld den Text ein, den Sie ersetzen wollen.
  3. Geben Sie im Ersetzen mit-Feld den neuen Text ein.
  4. Wählen Sie weitere Optionen, die Sie wünschen.
    Klicken Sie hier, um mehr über die Optionen zu erfahren.
  5. Klicken Sie auf Weitersuchen, Ersetzen oder Alle ersetzen.

Verwandte Themen

  • Suchen/Ersetzen-Dialog


Weitersuchen oder rückwärts suchen

Sie können schnell zum nächsten oder vorherigen Vorkommen des Suchtextes navigieren.

Um das nächste Vorkommen zu finden...

  • Klicken Sie im Suchen-Menü auf Weitersuchen oder drücken Sie F3.

Um das vorherige Vorkommen zu finden...

  • Klicken Sie im Suchen-Menü auf Rückwärts suchen oder drücken Sie Strg+F3.

Hinweis

  • Sie können auch auf Weitersuchen [image] oder Rückwärts suchen [image] in der Symbolleiste klicken.

Verwandte Themen

  • Verwenden der Suchleiste


Passende Klammer suchen

Um die passende Klammer zu finden...

  • Klicken Sie im Suchen-Menü auf Passende Klammer.


Suchen/Ersetzen-Dialog

Der Suchen/Ersetzen-Dialog erlaubt das Suchen und Ersetzen von Text.

Suchen nach

Gibt den Suchtext an.

Ersetzen mit

Gibt den neuen Text an.

Weitersuchen

Sucht den angegebenen Text.

Alle suchen

Sucht alle Vorkommen des Suchtexts und zeigt die Ergebnisse als Liste.

Ersetzen

Ersetzt den Suchtext mit dem neuen Text und sucht nach dem nächsten Vorkommen des Suchtexts.

Alle ersetzen

Ersetzt alle Vorkommen des Suchtexts mit dem neuen Text.

Mehrzeilig

Ermöglicht das Umschalten zwischen einzeilig und mehrzeilig.

Optionen

Groß/Kleinschreibung beachten

Bei der Suche muss die Groß/Kleinschreibung des Suchtexts in Suchen nach mit dem Text übereinstimmen.

Nur ganze Wörter

Sucht nur nach ganzen Wörtern von Suchen nach und nicht nach Bruchstücken der Wörtern.

Reguläre Ausdrücke

Aktiviert die Suche mit regulären Ausdrücken.

Groß/Klein beibehalten

Behält die Groß/Kleinschreibung des zu ersetzenden Texts bei.

Wenn beispielsweise der Suchtext hello und der neue Text world ist, dann wird Hello durch World und HELLO durch WORLD ersetzt.

Richtung

Vorwärts

Sucht den Text vom Anfang des Texts aus.

Rückwärts

Sucht den Suchtext vom Ende des Texts aus.

Anfang

Ab Cursor

Sucht den Suchtext aber der aktuellen Cursorposition.

Gesamter Umfang

Beginnt die Suche am Anfang des Dokuments.

Umfang

Aktuelles Dokument

Sucht den Text in allen Texten.

Alle offenen Dokumente

Sucht in allen geöffneten Dokumenten.

Markierter Text

Sucht nur im markierten Textbereich.

Verwandte Themen

  • Reguläre Ausdrücke verwenden


Suchen/Ersetzen in Dateien

In Dateien suchen erlaubt die Suche nach Text in Dateien auf Ihrem Datenträger.

Suchen nach

Gibt den Suchtext an.

Ersetzen mit

Gibt den neuen Text an.

Suchen in

Gibt den Ordner an, in dem nach Dateien gesucht werden soll.

In Unterordner suchen

Mit dieser Option wird festgelegt, dass auch in Unterordnern des Ordners, der im Suchen in-Feld eingegeben wurde, gesucht wird.

Dateityp

Gibt den Typ der Dateien an, die in die Suche eingeschlossen werden. Dieses Feld enthält gültige Dateimasken, getrennt durch ;

Suchen

Sucht nach allen Vorkommen des Suchtexts.

Ersetzen

Sucht nach allen Vorkommen des Suchtexts und erlaubt das Ersetzen.

Alle ersetzen

Ersetzt alle Vorkommen des Suchtexts mit dem neuen Text.

Durchsuchen

Öffnet den Suche nach Ordner-Dialog, mit dem Sie den Suchen in-Ordner auswählen können, wenn Sie ihn nicht mit der Tastatur eingeben wollen.

Schließen

Schließt den In Dateien suchen-Dialog und bricht die aktuelle Suche ab (falls eine am Laufen war).

Nach Abschluß der Suche schließen

Mit dieser Option wird der In Dateien suchen-Dialog geschlossen, wenn die Suchoperation durchgeführt wurde.

Optionen

Groß/Kleinschreibung beachten

Bei der Suche muss die Groß/Kleinschreibung des Suchtexts in Suchen nach mit dem Text übereinstimmen.

Nur ganze Wörter

Sucht nur nach ganzen Wörtern von Suchen nach und nicht nach Bruchstücken der Wörtern.

Reguläre Ausdrücke

Aktiviert die Suche mit regulären Ausdrücken.

Groß/Kleinschreibung beibehalten

Mit dieser Option wird festgelegt, dass die Groß/Kleinschreibung des Suchtexts auch beim neuen Text verwendet wird. Die Tabelle unten zeigt ein Beispiel, wie diese Option die Ersetzen-Funktion anwendet. In diesem Beispiel ist der Suchtext software und der neue Text lautetnd the replacement string is program.

Gefundener Text | Eingefügter Text
software | program
Software | Program
SOFTWARE | PROGRAM

Detailierte Resultate anzeigen

Mit dieser Option zeigt das Suchergebnis auch die Position des Vorkommens des Suchtexts an. Wenn diese Option nicht aktiv ist, zeigt das Suchergebnis nur die Dateinamen.


Verwenden von regulären Ausdrücken

Suchen und Ersetzen unterstützt reguläre Ausdrücke, so dass Sie auch mit Mustern arbeiten können.

Operatoren der regulären Ausdrücke

^ | Ein Zirkumflex am Anfang einer Zeichenkette entspricht dem Start einer Zeile.
$ | Ein Dollarzeichen am Ende des Ausdrucks entspricht dem Ende der Zeile.
. | Ein Punkt entspricht einem beliebigen Zeichen.
* | Ein Stern nach einer Zeichenkette entspricht keinem oder eine beliebigen Anzahl von Vorkommen dieser Zeichenkette.
+ | Ein Pluszeichen nach einer Zeichenkette entspricht einem oder mehreren Vorkommen der Zeichenkette.
[ ] | Zeichen in Klammern entsprechen jedem beliebigen Zeichen, das in den Klammern vorkommt, aber keinem anderen.
[^] | Ein Zirkumflex am Anfang der Zeichenkette in Klammern entspricht NOT.
[-] | Ein Bindestrich innerhalb von Klammern bedeutet eine Zeichenbereich. Beispiel: [a-z] entspricht einem beliebigen Zeichen von a bis z.
( ) | Geschweifte Klammern gruppieren Zeichen oder Ausdrücke.

Beispiele

ab+ | Entspricht ab, abb, abbb ...
ab* | Entspricht a, ab, abb ...
a(bc)+ | Entspricht abc, abcbc ...
<img[^]+> | Entspricht HTML-Bild-Tags, z.B. <img src="image.gif">
[a-z0-9]+ | Entspricht einem beliebigen alphanumerischen Wort, z.B. abc, 123, abc123 ...

Escape-Operatoren

Um nach Zeichen zu suchen, die Operatoren der regulären Ausdrücken entsprechen, müssen Sie diese mit \ escapen. Beispielsweise \^ entspricht ^ und schaut nicht nach dem Start einer Zeile.


Verwenden von Lesezeichen

Mit einem "Lesezeichen" kann man eine Stelle in einer Datei markieren. Wenn Sie ein Lesezeichen in einer Zeile gesetzt haben, können Sie mit dem Menü oder Tastenbefehlen zu diesen Zeilen springen.

Um ein Lesezeichen zu setzen oder aufzuheben...

  1. Bewegen Sie den Cursor an die Steleln, an der Sie ein Lesezeichen setzen oder aufheben wollen.
  2. Klicken Sie im Suchen-Menü auf Lesezeichen umschalten [image].

Um zu einem Lesezeichen zu springen...

  • Klicken Sie im Suchen-Menü auf Gehe zu Lesezeichen und wählen Sie die Nummer des Lesezeichens.
  • Sie können auch mit Nächstes Lesezeichen [image] und Vorheriges Lesezeichen [image], um schnell zwischen Lesezeichen zu wechseln.

Um zu einem Lesezeichen zu springen...

  • Klicken Sie im Suchen-Menü auf Gehe zu Lesezeichen und wählen Sie die Nummer des Lesezeichens.
  • Sie können auch mit Nächstes Lesezeichen [image] und Vorheriges Lesezeichen [image], um schnell zwischen Lesezeichen zu wechseln.

Hinweis

  • Um alle Lesezeichen auf einmal zu löschen, klicken Sie auf Alle Lesezeichen löschen [image] im Suchen-Menü.


Verwenden der Suchleiste

Die Suchleiste erlaubt die schnelle Suche und den Zugriff auf Suchbefehle.

Suchleistenbefehle

Das Suchfeld ermöglichte eine schnelle Suche. Geben Sie den Text ein und drücken Sie auf Eingabe.
 | Suchen ermöglicht den schnellen Zugriff auf den Suchen-Befehl.
 | Ersetzen ermöglicht den schnellen Zugriff auf den Ersetzen-Befehl.
 | Rückwärts suchen ermöglicht das schnelle Auffinden des vorherigen Vorkommens des letzten Suchtextes.
 | Weitersuchen ermöglicht das schnelle Auffinden des nächsten Vorkommens des letzten Suchtextes.
 | In Dateien suchen ermöglicht den schnellen Zugriff auf den In Dateien suchen-Befehl.
 | Passende Klammer sucht nach der passenden Klammer.


Zur nächsten oder vorherigen Klammer gehen

Sie können sich leicht zwischen den passenden Klammern bewegen.

Die folgenden Befehle sind verfügbar

  • Um zur gegenüberliegenden Klammer zu gelangen drücken Sie Strg+Alt+Links (dies ist das Standardkürzel, dass Sie ändern können).
  • Um den Text zwischen den Klammern zu markieren, drücken Sie Strg+Alt+Rechts (dies ist das Standardkürzel, dass Sie ändern können).


Text mit Drag&Drop verschieben

Sie können die Maus zum Bewegen oder Kopieren von Text innerhalb eines Dokuments verwenden:

Um den markierten Text zu verschieben...

  1. Halten Sie die linke Maustaste in der Auswahl gedrückt.
  2. Ziehen Sie den Cursor an die neue Stelle.
  3. Lassen Sie die Maustaste los.

Um den markierten Text zu kopieren...

  1. Halten Sie die Strg und linke Maustaste in der Auswahl gedrückt.
  2. Ziehen Sie den Cursor an die neue Stelle.
  3. Lassen Sie die Maustaste los.

Um den Drag&Drop-Vorgang abzubrechen...

  • Drücken Sie Esc oder
  • Drücken Sie auf die rechte Maustaste oder
  • Lassen Sie die Maustaste in der Auswahl los.

Hinweis

  • Die Strg-Taste kann jederzeit vor dem Loslassen der linken Maustaste gedrückt oder losgelassen werden, um aus dem Ziehen ein Kopieren oder Bewegen zu machen.


Texteinzug

Sie können den Texteinzug erhöhen oder verkleinern, um Ihren Code zu formatieren.

Um den Texteinzug zu vergrößern...

  1. Markieren Sie den Text
  2. Klicken Sie im Bearbeiten-Menü auf Einzug vergrößern oder drücken Sie Umschalt+Strg+I

Um den Texteinzug zu verkleinern...

  1. Markieren Sie den Text
  2. Klicken Sie im Bearbeiten-Menü auf Einzug verkleinern oder drücken Sie Umschalt+Strg+U

Hinweis

  • Sie können auch die Schaltflächen Einzug [image] und Einzug - [image] in der Symbolleiste.


Rechtschreibprüfung

Um die Rechtschreibung im aktuellen Dokument zu prüfen...

  1. Klicken Sie im Werkzeuge-Menü auf Rechtschreibprüfung.
  2. Bei jedem unbekannten Wort wird ein Dialog erscheinen.
  3. Im Rechtschreibprüfung-Dialog:
    • Um ein unbekanntes Wort zu ersetzen, wählen Sie Ändern.
    • Um ein unbekannte Wort zu überspringen, wählen Sie Ignorieren.
    • Um alle unbekannten Wörter zu überspringen, klicken Sie auf Alle ignorieren.
    • Um das Wort in das Wörterbuch aufzunehmen, klicken Sie auf Hinzufügen.
    • Um die Rechtschreibprüfung zu beenden, klicken Sie auf Abbrechen.

Hinweis

  • Sie können unbekannte Wörter mit einer roten Unterstreichung hervorheben. Um die Hervorhebung unbekannter Wörter zu aktivieren/deaktivieren, klicken Sie im Optionen-Menü auf Auto-Rechtschreibprüfung

Verwandte Themen

  • Sprache der Rechtschreibprüfung ändern


Erweiterte Zwischenablage

Die erweiterte Zwischenablage sammelt Einträge, wenn Sie kopieren und ausschneiden. Sie können Sie dann einfügen oder in Ihr Dokument ziehen.

Um den Inhalt der erweiterten Zwischenablage anzusehen, klicken Sie im Bearbeiten-Menü auf Erweiterte Zwischenablage. Die Zwichenablage-Leiste wird erscheinen.

Um einen Eintrag aus der erweiterten Zwischenablage in Ihr Dokument einzufügen, ziehen Sie es einfach aus der Zwischenablage-Leiste an die gewünschte Stelle in Ihrem Text.

Hinweis

  • Mit einem Doppelklick auf den Eintrag in der Zwischenablage-Leiste wird der Eintrag in Ihr Dokument an der Cursorposition eingefügt.


Echtzeit-Syntaxprüfung

Die Echtzeit-Syntaxprüfung führt die Syntaxprüfung während der Codebearbeitung durch. Die Echtzeit-Syntaxprüfung wird gestartet, wenn sich die Zeilenanzahl in einer Datei ändern (z.B. wenn Zeilen gelöscht oder eingefügt werden).

Die Echtzeit-Syntaxprüfung unterstützt die folgenden Sprachen:

  • PHP
  • Ruby

Um die Funktion an- oder abzuschalten...

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen.
  2. Klicken Sie in den Voreinstellungen auf den PHP (Ruby) Einstellungen-Ordner.
  3. Aktivieren/deaktivieren Sie die Option Echtzeit-PHP (Ruby)-Syntaxprüfung.
  4. Stellen Sie sicher, dass Sie den richtigen Pfad zur EXE von PHP (Ruby) in den Voreinstellungen eingegeben haben (php.exe beziehungsweise ruby.exe).
  5. Klicken Sie auf OK.

Verwandte Themen:

  • Syntaxprüfung der PHP-Datei


HTML und XHTML bearbeiten

Spezielle Hilfen zum Schreiben von Code ermöglichen Ihnen, sofort HTML- und XHTML-Code zu erstellen, zu bearbeiten und zu validieren.

Standardkompatibilität

Rapid PHP erstellt Code gemäß den gewählten HTML-Spezifikationen. Derzeit werden HTML 4.01, XHTML 1.0 und XHTML 1.1 unterstützt. Sie können die HTML-Spezifikationen für Rapid PHP wählen oder diese automatisch vornehmen lassen, basierend auf Ihrem HTML-DOCTYPE.

  • HTML-Spezifikation

HTML- und XHTML-Code schreiben

Rapid PHP bietet einige Werkzeuge, die das Bearbeiten von Code einfach und bequem machen. Der HTML-Codegeneratoren ermöglicht das sofortige Einfügen von HTML-Code, der Insepektor erlaubt das schnelle Ändern von HTML-Tags und das AutoVervollständigen hilft beim Schreiben von Tag- und Attributnamen.

  • Inspektor verwenden
  • AutoVervollständigen verwenden
  • HTML-Code erstellen

HTML- und XHTML-Code validieren

Sie können Ihren Code mit dem eingebauten Validator HTML-Tidy validieren und reparieren.

  • HTML-Tidy verwenden

Vorschau von HTML-Seiten

Sie können HTML-Dokumente direkt im Dokumentfenster anzeigen oder in jedem installierten Webbrowser öffnen.

  • Vorschau von HTML-Seiten


Inspektor verwenden

Der HTML-Inspektor erlaubt das schnelle Ändern eines HTML-Tags. Wenn der Cursor innerhalb eines HTML-Tags platziert wird, zeigt der Inspektor eine Liste der Attribute, die von dem Tag unterstützt werden. Der Code wird automatisch aktualisiert, wenn Sie Attributewerte durch Bearbeiten der Felder des Inspektors ändern.

Um den Inspektor zu aktivieren, klicken Sie im Ansicht-Menü auf Inspektor.

Hinweise

  • Einige Inspektor-Felder haben verbundene Schaltflächen. Diese Schaltflächen rufen Ausklappfelder oder Dialoge auf, die beim Eingeben von Attributwerten helfen.
  • Um ein Attribut mit dem Inspektor zu löschen, löschen Sie einfach dessen Wertfeld.

Verwandte Themen

  • HTML und XHTML bearbeiten
  • AutoVervollständigen verwenden


AutoVervollständigen verwenden

Das AutoVervollständigen hilft bei der schnellen Eingabe, indem eine Liste der gültigen Elemente und Attribute angezeigt wird, die Sie mit doppelklicken oder mit der Eingabe-Taste bestätigen.

Das AutoVervollständigen-Fenster wird automatisch angezeigt, wenn Sie Code eingeben. Sie können das AutoVervollständigen auch mit Strg+Leertaste aufrufen.

Hinweise

  • Das AutoVervollständigen kann über die Voreinstellungen deaktiviert werden.
  • Die Verzögerungszeit für das Erscheinen des AutoVervollständigen-Dialogs kann in den Voreinstellungen angepasst werden.
  • Zum Schließen des AutoVervollständigen-Dialogs klicken Sie Esc.

Verwandte Themen

  • HTML und XHTML bearbeiten
  • Inspektor verwenden


HTML-Code erstellen

Sie können HTML-Code mit Einfügen und Format-Menübefehlen und HTML und Format-Symbolleiste erstellen. Jeder Befehl fügt spezielle HTML-Sprachelemente ein. Beispielsweise fügt der Hyperlink [image] -Befehl ein HTML-Hyperlink-Tag ein.

Verwandte Themen

  • HTML und XHTML bearbeiten
  • AutoVervollständigen verwenden
  • Inspektor verwenden


HTML-Tidy verwenden

Über HTML-Tidy

HTML-Tidy ist ein mächtiges, kostenloses Tool zur Validierung und Formatierung von HTML- und XHTML-Dokumenten. Rapid PHP integriert sich mit diesem wunderschönen Tool und bietet eine komfortable Nutzung.

Tidy kann viele Probleme beseitigen und macht Sie auf Dinge aufmerksam, an denen Sie arbeiten sollten. Jeder gefundene Eintrag wird mit Zeilennummer und Spalten aufgelistet und Sie sehen, wo die Probleme in Ihrem Code liegen. Tidy kann keine bereinigte Version erstellen, wenn es Probleme gibt, bei denen nicht klar ist, wie sie behandelt werden müssen. Diese werden als "Fehler" und nicht als "Warnungen" protokolliert.

HTML-Tidy verwenden

HTML-Tidy kann einige schwierige Aufgaben durchführen. Jede Aufgabe muss erstellt und konfiguriert werden, bevor sie ausgeführt werden kann. Um Ihnen den Einstieg zu erleichtern, kommt Rapid PHP mit einem Satz von vordefinierten HTML-Tidy-Aufgaben.

Um einen der HTML-Tidy-Aufgaben auszuführen, müssen Sie im Werkzeuge-Menü ins HTML-Tidy-Untermenü wechseln und dort auf den Namen der Aufgabe klicken.

Wenn HTML-Tidy Ihr Dokument prüft, werden die erstellten "Fehler" und "Warnungen" in der Nachrichten-Leiste angezeigt. Sie können schnell zum Problembereich springen, indem Sie einen Doppelklick auf den Fehler oder die Warnung ausführen.

Um HTML-Tidy-Aufgaben zu konfiguriereren, wählen Sie im Werkzeuge-Menü das Untermenü HTML-Tidy und klicken auf Aufgaben verwalten.

Hinweise

  • HTML-Tidy arbeitet möglicherweise bei einigen PHP-Dateien nicht richtig.


Vorschau von HTML-Dokumenten

Sie können HTML-Dokumente direkt in Rapid PHP in der Vorschau oder in einem beliebigen Webbrowser anzeigen lassen.

Vorschau von HTML-Dokumenten direkt in Rapid PHP

Um die Vorschau eines HTML-Dokumente direkt in der Editor-Umgebung anzuschauen, klicken Sie auf Vorschau unten im Dokumentenfenster.

Sie können auch eine der Registerkarten Vertikal/Horizontal teilen am unteren Rand des Dokumentenfensters verwenden, um den Seitencode und die Vorschau gleichzeitig zu sehen.

Vorschau von HTML-Dokumenten in einem Webbrowser

  1. Klicken Sie im Werkzeuge-Menü auf Vorschau in.
  2. Klicken Sie im Vorschau in-Untermenü auf den Webbrowser, den Sie verwenden wollen.
  • Interne Vorschau
  • Vorschau-Symbolleiste verwenden


HTML- und XHTML-Online-Ressourcen

Voreinstellungen und Spezifikationen

  • HTML 4.01 Specification
  • XHTML 1.0 Specification
  • XHTML 1.1 Recommendation
  • HTML 4.01 Reference by W3Schools
  • XHTML 1.0 Reference by W3Schools

Tutorials

  • HTML Tutorial by W3Schools
  • XHTML Tutorial by W3Schools

Andere Ressourcen

  • W3 MarkUp Validation Service


Stylesheets bearbeiten

Spezielle Hilfen zum Schreiben von CSS-Code ermöglichen Ihnen, sofort Cascading Style Sheets zu erstellen und zu bearbeiten.

Standardkompatibilität

Rapid PHP erstellt Code gemäß den gewählten CSS-Spezifikationen. Derzeit werden CSS Level 1, CSS Level 2 und einige andere Spezifikationen unterstützt. Sie können die CSS-Spezifikation auswählen, mit der Sie arbeiten wollen.

  • CSS-Spezifikation

CSS-Code schreiben

Rapid PHP bietet einige Werkzeuge, die das Bearbeiten von Code einfach und bequem machen. Beim schnellen Einfügen von CSS-Code hilft Ihnen die CSS-Symbolleiste, der Inspektor unterstützt beim Hinzufügen von Eigenschaften und beim bequemen Ändern von Werten und das AutoVervollständigen hilft beim Einfügen von Eingenschaftsnamen bei der Eingabe.

  • CSS-Code erstellen
  • Inspektor verwenden
  • AutoVervollständigen verwenden

CSS-Code validieren

Sie können Ihren CSS-Code auf Fehler prüfen, indem Sie die CSS-Prüfung und den W3 CSS Validator verwenden.

  • CSS-Code validieren

Vorschau von Stylesheets

Sie können CSS direkt im Dokumentfenster anzeigen oder in jedem installierten Webbrowser.

  • Vorschau von Stylesheets


CSS-Code erstellen

Mit Rapid PHP können Sie schnell CSS-Code erstellen und bearbeiten, mit wenig oder gar keiner Tipparbeit.

Die folgenden Themen bieten weitere Informationen:

  • Arbeiten mit Selektoren und Regeln
  • Allgemeine Eigenschaften bearbeiten
  • Inspektor verwenden
  • AutoVervollständigen verwenden


Mit Selektoren und Regeln arbeiten

Selektoren können einfach erstellt, gelöscht und dupliziert werden, indem man das CSS-Menü bzw. die Symbolleiste verwendet.

Die folgenden CSS-Menü und Symbolleisten-Befehle sind für die Arbeit mit Selektoren verfügbar:

Selektor erstellen öffnet den Dialog Neuer Selektor, der neue Selektoren basieren auf den von Ihnen gewählten Optionen erstellt.
Selektor duplizieren öffnet den Dialog Neuer Selektor, der neue Selektoren basierend auf den von Ihnen gewählten Optionen erstellt und dabei die Reglen des aktuellen Selektors verwendet.
Selektor löschen löscht den aktuellen Selektor.

Verwandte Themen

  • Neuer Selektor
  • Stylesheets bearbeiten
  • Allgemeine Eigenschaften bearbeiten
  • CSS-Explorer verwenden


Allgemeine Eigenschaften bearbeiten

Sie können die allgemeinen Format-Eigenschaften schnell und einfach ohne Tipparbeit ändern, indem Sie das CSS-Menü und die Symbolleiste verwenden.

Die folgenden CSS-Menü und -Symbolleisten-Befehle sind für das schnelle Ändern der Eingenschaften des aktuellen Selektors verfügbar:

 | Schriftart zeigt Schriftartauswahl-Dialog und erstellt die font-family-Eigenschaften basierend auf den gewählten Schriftarten.
 | Fett (Bold) fügt font-weight: bold ein oder entfernt es.
 | Kursiv (Italic) fügt font-style: italic ein oder entfernt es.
 | Unterstreichen (Underline) fügt text-decoration: underline hinzu oder entfernt es.
 | Linksbündig (Left) fügt text-align: left ein oder entfernt es.
 | Zentriert (Center) fügt text-align: center hinzu oder entfernt es.
 | Rechtsbündig (Right) fügt text-align: right hinzu oder löscht es.
 | Blocksatz (Justify) fügt text-decoration: justify hinzu oder entfernt es.
 | Linienhöhe (Line Height) erstellt eine line-height-Eigenschaft.
 | Textfarbe (Text Color) zeigt den Farbwähler-Dialog und erstellt Farb-Eigenschaften basierend auf der ausgewählten Farbe.
 | Hintergrundfarbe (Background Color) zeigt den Farbwähler-Dialog und erstellt eine background-color-Eigenschaft basierend auf der gewählten Farbe.
Die CSS-Symbolleiste zeigt Schriftart- und Schriftgröße-Auswaahlfelder für die Änderung der Eigenschaftenfont-family und font-size.

Verwandte Themen

  • Stylesheets bearbeiten
  • Arbeiten mit Selektoren
  • AutoVervollständigen verwenden
  • Inspektor verwenden


Inspektor verwenden

Sie können den Inspektor verwenden, um schnell Stil-Eigenschaften und Werte hinzufügen, entfernen oder ändern können, ohne den Code direkt bearbeiten zu müssen.

Wenn der Cursor innerhalb der { und }-Kammern steht, zeigt der Inspektor eine Liste der unterstützten Eigenschaften. Der Code wird automatisch aktualisiert, wenn Sie die Eigenschaftswerte ändern.

Um den Inspektor zu aktivieren, klicken Sie im Ansicht-Menü auf Inspektor.

Hinweise

  • Einige Inspektor-Felder haben verbundene Schaltflächen. Diese Schaltflächen rufen Ausklappfelder oder Dialoge auf, die beim Eingeben von Eigenschaftswerten helfen.
  • Um eine Eigenschaft mit dem Inspektor zu entfernen, löschen Sie einfach dessen Wert.

Verwandte Themen

  • Stylesheets bearbeiten
  • Allgemeine Eigenschaften bearbeiten
  • AutoVervollständigen verwenden


AutoVervollständigen verwenden

Das AutoVervollständigen hilft bei der schnellen Eingabe, indem eine Liste der gültigen Eigenschaften angezeigt wird, die Sie mit doppelklicken oder mit der Eingabe-Taste bestätigen.

Das AutoVervollständigen-Fenster wird automatisch angezeigt, wenn Sie Code eingeben. Sie können das AutoVervollständigen auch mit Strg+Leertaste aufrufen.

Hinweise

  • Das AutoVervollständigen kann über die Voreinstellungen deaktiviert werden.
  • Die Verzögerungszeit für das Erscheinen des AutoVervollständigen-Dialogs kann in den Voreinstellungen angepasst werden.
  • Zum Schließen des AutoVervollständigen-Dialogs klicken Sie Esc.

Verwandte Themen

  • Stylesheets bearbeiten
  • Inspektor verwenden


Code-Explorer verwenden

Der Code-Explorer listet alle CSS-Selektoren, die im aktuellen Dokument enthalten sind. Sie können zu einem Selektor navigieren, indem Sie auf ihn klicken. Er wird dadurch zum aktuellen Selektor.

Um den Code-Explorer zu aktivieren, klicken Sie im Menü Ansicht auf Code-Explorer. Stellen Sie sicher, dass die CSS-Option im unteren Teil der Code-Explorer-Leiste aktiviert ist.

Der Code-Explorer aktualisiert sich automatisch, wenn der Code bearbeitet wird, aber Sie können die Aktualisierung auch jederzeit manuell aktivieren, indem Sie auf die Aktualisieren-Schaltfläche klicken.

Hinweis

  • Sie können im Code-Explorer mit einem Rechtsklick ein Auswahlmenü mit Befehlen für die Arbeit mit Selektoren aufrufen.

Verwandte Themen

  • Stylesheets bearbeiten
  • Arbeiten mit Selektoren


Vorschau von Stylesheets

Sie können Stylesheets direkt in Rapid PHP in der Vorschau oder in einem beliebigen Webbrowser anzeigen lassen.

Vorschau von HTML-Dokumenten direkt in Rapid PHP

Um die Vorschau eines CSS-Dokumente direkt in der Editor-Umgebung anzuschauen, klicken Sie auf Vorschau unten im Dokumentenfenster.

Sie können auch eine der Registerkarten Vertikal/Horizontal teilen am unteren Rand des Dokumentenfensters verwenden, um den Seitencode und die Vorschau gleichzeitig zu sehen.

Stylesheets können auf zwei Arten in der Vorschau erscheinen

  • Basierend auf einer automatisch erzeugten Webseite, die einen Inhalt für jeden Selektor enthält
  • Basierend auf eine HTML-Dokument Ihrer Wahl

Die Vorschau von Stylesheets kann in der Vorschau-Symbolleiste gewählt werden. Klicken Sie hier, um mehr darüber zu erfahren.

Um ein CSS-Dokument in einer Webbrowser-Vorschau anzuzeigen...

  1. Klicken Sie im Werkzeuge-Menü auf Vorschau in.
  2. Klicken Sie im Vorschau in-Untermenü auf den Webbrowser, den Sie verwenden wollen.

Verwandte Themen

  • Interne Vorschau
  • Vorschau-Symbolleiste verwenden


CSS-Code validieren

Sie können Ihren CSS-Code mit der Funktion CSS-Prüfung validieren.

Um eine CSS-Datei zu validieren...

  1. Klicken Sie im CSS-Menü auf CSS-Prüfung.

Hinweise

  • Um eine fortschrittlichere Validierung durchzuführen, können Sie den offiziellen Online-Validierungs-Service mit dem W3C CSS Validator-Befehl im CSS-Menü verwenden.

Verwandte Themen

  • Stylesheets bearbeiten


Schriftartauswahl-Dialog

Schriftart auswählen erlaubt die Auswahl von Schriftarten für die CSS font-family-Eigenschaft.

Generische Schriftarten

Listet alle generischen Schriftarten.

Um eine generische Schriftart auszuwählen, klicken Sie auf sie. Hinweise: Sie können immer nur eine generische Schriftart zur gleichen Zeit auswählen.

Eine generische Schriftart wird verwendet, wenn keine anderer angegebene Schriftart auf dem Zielsystem verfügbar ist.

Installierte Schriftarten

Listet alle auf dem aktuellen System verfügbaren Schriftarten.

Wählen Sie eine Schriftart, indem Sie sie markieren. Sie können die Auswahl aufheben, indem Sie die Markierung entfernen.

Voreinstellungen

Listet häufig verwendete Schriftarten-Kombinationen.

Um eine Voreinstellung zu verwenden, klicken Sie auf sie. Um die gerade markierten Schriftarten als Voreinstellung zu speichern, klicken Sie auf Hinzufügen. Um eine Voreinstellung zu löschen, wählen Sie sie aus und klicken Sie auf Löschen.

Hinzufügen

Speichert den Inhalt der gewählten Schriftarten in der Voreinstellungen-Liste.

Löschen

Löscht die derzeit markierten Elemente von der Voreinstellungen-Liste.

Markierte Schriftarten

Enthält eine Liste der markierten Schriftarten, die als Angabe für font-family verwendet werden.


Neuer Selektor

Der Neuer Selektor-Dialog erstellt neue CSS-Selektoren.

HTML-Element

Gibt das HTML-Element an, zu dem der Selektor gehört.

Pseudo-Element

Gibt das Pseudo-Element des Selektors an (falls es eines gibt).

Pseudo-Elemente werden in CSS verwendet, um verschiedene Effekte zu einigen Selektoren oder zu Teilen von einigen Selektoren hinzuzufügen.

Die Syntax von Pseudo-Klassen:
selektor:pseudo-element { eigenschaft: wert }

Pseudo-Klasse

Gibt die Pseudo-Klasse Selektors an (falls es eine gibt).

Pseudo-Klassen werden in CSS verwendet, um verschiedene Effekte zu einigen Selektoren oder zu Teilen von einigen Selektoren hinzuzufügen.

Die Syntax von Pseudo-Klassen:
selektor:pseudo-klasse { eigenschaft: wert }

Klasse, ID

Enthält den Klassennamen oder die ID zum Erstellen von Klassen- oder ID-Selektoren.

Selektor

Enthält den aktuell erzeugten Selektor. Sie können den Wert mit der Tastatur eingeben oder die vorher beschriebene Methode verwenden, diesen zu erstellen.

Hinzufügen

Fügt den Inhalt des Selektor-Felds zur Selektoren-Liste hinzu. Die Liste enthält Selektoren, die erstellt werden sollen.

Entfernen

Entfernt das markierte Element von der Selektoren-Liste.

Selektoren

Enthält Selektoren, die erstellt werden sollen.

Als einzelnen Selektor einfügen

Die Selektoren der Liste werden gruppiert und als eine Regel eingefügt.

Als getrennte Selektoren einfügen

Es wird eine Regel für jeden einzelnen Selektor der Liste erstellt.

Verwandte Themen

  • Arbeiten mit Selektoren und Regeln


Box-Eigenschaften bearbeiten

Der Box-Eigenschaften bearbeiten-Dialog erlaubt das schnelle Ändern der CSS-Border, -Margin und -Padding-Eigenschaften.

Visuelle Legende

Zeigt visuell Margin, Border und Padding eines Elements. Sie können auf das Bild klicken, um schnell den Editor für Margin, Border oder Padding aufzurufen.

Vorschau

Zeigt die Vorschau der gewählten Eigenschaften.

Margin

Erlaubt das Einstellen der Margin-Breiten-Eigenschaften. Das Margin-Feld erlaubt das Einstellen einer einheitlichen Margin um das Objekt. Die anderen Felder ermöglichen die Eingabe getrennter Margin-Breitenwerte für jede Seite des Elements.

Border

Ermöglicht das Einstellen der Breite, des Stils und der Farbe des Borders. Das Border-Feld ermöglicht das Einstellen eines einheitlichen Borders um das Objekt. Die anderen Felder ermöglichen die Eingabe getrennter Border-Eigenschaften für jede Seite des Elements.

Padding

Ermöglicht das Einstellen der Padding-Eigenschaften. Das Padding-Feld ermöglicht das Einstellen eines einheitlichen Paddings um die Objektgrenzen. Die anderen Felder ermöglichen die Eingabe getrennter Padding-Werte für jede Seite des Elements.


Stylesheet-Online-Ressourcen

Voreinstellungen und Spezifikationen

  • W3 CSS Level 1 Recommendation
  • W3 CSS Level 2 Specification
  • CSS Level 2 Reference by W3Schools

Tutorials

  • Introduction to CSS by Dave Raggett
  • Style Sheet Guide by Webmonkey
  • CSS Level 2 Reference by W3Schools

Andere Ressourcen

  • W3 CSS Validation Service


Bearbeiten von PHP-Code

Rapid PHP bietet einige Funktionen und Werkzeuge, die das Schreiben und Bearbeiten von PHP-Code effizienter machen.

Schreiben von PHP-Code

Werkzeuge in der PHP-Menü und -Symbolleiste erlauben das Einfügen von Teilen in PHP-Code. Das AutoVervollstädigen hilft beim Merken und schnellen Einfügen von Variablennamen. Funktionshinweise helfen beim Nachschlagen von Funktionsparametern ohne die Dokumentation verwenden zu müssen.

  • PHP-Menü und -Symbolleiste
  • PHP-Funktionshinweise verwenden
  • AutoVervollständigen verwenden

Navigierung durch PHP-Code

Sie können den Code-Explorer zur einfachen Navigation durch Ihre PHP-Script verwenden. Der Code-Explorer listet Klassen, Funktionen, Variablen und Includes, die in den Scripts enthalten sind und Sie können sich damit schnell durch Ihren Code bewegen.

  • PHP-Code-Explorer

PHP-Code prüfen

Sie können Ihr PHP-Script auf Syntaxfehler prüfen, indem Sie die Syntaxprüfung verwenden.

  • Syntaxprüfung der PHP-Datei

Vorschau von PHP-Dokumenten

Nachdem Sie Rapid PHP für die Zusammenarbeit mit Ihrem Webserver konfiguriert haben, können Sie PHP-Dokumente direkt im Dokumentfenster anzeigen oder in jedem installierten Webbrowser öffnen.

  • Vorschau von PHP-Seiten

Verwandte Themen

  • Bearbeiten von HTML und XHTML


PHP-Menü und -Symbolleiste

Mit der PHP-Menü und -Symbolleiste können Sie schnell die allgemeinen PHP-Codefragmente einfügen und haben Zugriff auf einige PHP-Tools.

PHP-Snippets bieten ein Auswahlmenü für das Einfügen allgemeiner PHP-Strukturen. Um dieses Menü zu bearbeiten, klicken Sie auf PHP-Snippets bearbeiten.
PHP-Servervariable zeigt eine Liste der Servervariablen. Um ein Element einzufügen, markieren Sie es und klicken auf OK.
PHP Tag fügt PHP-Tags <? ?> ein.
PHP-Block fügt PHP Tags <? und ?> in eine separate Zeile ein und erstellt damit einen mehrzeiligen PHP-Codeblock.
PHP-Ausgabe-Tag fügt ein PHP-Ausgabe-Tag <?= ?> ein.
Datei einfügen fügt die Include-Directive für eine Datei ein.
Require fügt eine Datei-Require-Directive ein.
Kommentarblock fügt einen leeren PHP-Kommentarblock /* */ ein oder konvertiert den markierten Text in einen Kommentarblock.
Zeilenkommentar fügt einen einzeiligen PHP-Kommentar // ein oder konvertiert den markierten Text in Kommentarzeilen.
HTML in PHP umwandeln konvertiert den markierten HTML-Code in reinen PHP-Code, der HTML ausgibt.
Syntaxprüfung prüft das aktuelle PHP-Dokument auf Syntaxfehler.

Sprachbrowser

Der Sprachbrowser bietet einen einfachen Weg, um mit PHP-Projekten zu arbeiten.

  • Sprachbrowser


PHP-Funktionshinweise verwenden

Funktionshinweise helfen beim Nachschlagen von PHP-Funktionsparametern ohne die Dokumentation verwenden zu müssen.

Funktionshinweise werden angezeigt, wenn Sie ( nach einem PHP-Funktionsnamen eingeben.

Alternativ können Sie den Cursor innerhalb der Klammern eines PHP-Funktionsaufrufs platzieren und Umschalt+Strg+Leertaste drücken, um den Hinweis bei Bedarf einzublenden.

Verwandte Themen

  • Bearbeiten von PHP-Code


AutoVervollständigen verwenden

Das AutoVervollständigen hilft bei der schnellen Eingabe, indem eine Liste der gültigen Eigenschaften angezeigt wird, die Sie mit doppelklicken oder mit der Eingabe-Taste bestätigen.

Den AutoVervollständigen-Dialog können Sie mit Strg+Leertaste öffnen. Sie können das AutoVervollständigen auch so einstellen, dass es automatisch erscheint.

Hinweise

  • Die Optionen des AutoVervollständigen können in den Voreinstellungen angepasst werden.
  • Die Verzögerungszeit für das Erscheinen des AutoVervollständigen-Dialogs kann in den Voreinstellungen angepasst werden.
  • Zum Schließen des AutoVervollständigen-Dialogs klicken Sie Esc.

Verwandte Themen

  • Bearbeiten von PHP-Code


Code-Explorer verwenden

Der Code-Explorer listet Klassen, Funktionen, Variablen und Includes, die in den Scripts enthalten sind und Sie können sich damit schnell durch Ihren Code bewegen. Sie können zu einem Eintrag navigieren, indem Sie auf ihn klicken.

Um den Code-Explorer zu aktivieren, klicken Sie im Menü Ansicht auf Code-Explorer. Stellen Sie sicher, dass die PHP-Option im unteren Teil der Code-Explorer-Leiste aktiviert ist.

Der Code-Explorer aktualisiert sich automatisch, wenn Sie mit der Maus darüber fahren, aber Sie können die Aktualisierung auch jederzeit manuell aktivieren, indem Sie auf die Aktualisieren-Schaltfläche klicken.

Hinweis

  • Standardmäßig werden PHP-Variablen nicht im Code-Explorer angezeigt. Um Variablen anzuzeigen, wählen Sie in der Code-Explorer-Symbolleiste auf Optionen und aktivieren die Option Variablen anzeigen.

Verwandte Themen

  • Bearbeiten von PHP-Code


PHP-Syntaxprüfung

Die Syntaxprüfung prüft Ihr PHP-Script auf Syntaxfehler.

Um eine Syntaxprüfung durchzuführen...

  1. Klicken Sie im PHP-Menü auf Syntaxprüfung.

Hinweise

  • Klicken Sie auf Syntaxprüfung [image] in der PHP-Symbolleiste.
  • Um diese Funktion zu verwenden, muss PHP auf Ihrem Computer installiert sein. Sie müssen den Pfad zur php.exe in den Voreinstellungen eingeben, die sie über das Optionen-Menü aufrufen können.

Verwandte Themen

  • Bearbeiten von PHP-Code


Vorschau von PHP-Seiten

Um PHP-Seiten in der Vorschau sehen zu können, müssen Sie Ihren Rapid PHP-Editor so konfigurieren, dass er mit Ihrem Webserver zusammenarbeitet.

Rapid PHP für die Zusammenarbeit mit einem Webserver konfigurieren

Server Side Scripts wie PHP oder ASP müssen auf dem Webserver ausgeführt werden, bevor eine Vorschau erzeugt werden kann. Rapid PHP bieten eine Funktion namens Zuordnungen, die Scripts für die Vorschau an den Webserver weiterleitet.

Zuordnungen erlauben das Zuordnen Ihres lokalen Dateisystems oder FTP-Ordners zu Ihren Webadressen. Beispielsweise können Sie c:\wwwroot der URL http://localhost/ zuordnen

Um Zuordnungen hinzuzufügen, zu bearbeiten oder zu entfernen:

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen.
  2. In den Voreinstellungen klicken Sie auf den Vorschau-Ordner.
  3. Klicken Sie auf Zuordnungen.
  4. Klicken Sie auf Hinzufügen, Löschen oder Bearbeiten, um Zuordnungen zu bearbeiten.

Sie können PHP-Seiten direkt in der Vorschau von Rapid PHP sehen oder im gewünschten Webbrowser.

Vorschau von PHP-Seiten

Vorschau von HTML-Dokumenten direkt in Rapid PHP

Um PHP-Seiten schnell in der Vorschau sehen zu können, ohne die Editierumgebung verlassen zu müssen, klicken Sie auf das Vorschau-Register unten im Dokumentenfenster.

Um PHP-Dokumente in einer Webbrowser-Vorschau anzuzeigen...

  1. Klicken Sie im Werkzeuge-Menü auf Vorschau in.
  2. Klicken Sie im Vorschau in-Untermenü auf den Webbrowser, den Sie verwenden wollen.

Hinweis

  • Sie müssen auf Ihrem Computer einen Webserver mit PHP-Support installiert haben, um PHP-Scripts lokal ohne Hochladen in das Web in der Vorschau sehen zu können.

Verwandte Themen

  • Tutorial: Konfigurieren der PHP-Vorschau


PHP-Scripts debuggen

Wenn Sie schon einmal mit einem Code-Debugger gearbeitet haben, wird die eingebaute Debugfunktion sehr hilfreich für Sie sein.

Um die PHP-Debugfunktion verwenden zu können, müssen Sie PHP auf Ihrem Computer installiert haben und die xDebug-Erweiterung zu Ihrem PHP-Setup hinzufügen.

Die folgenden Themen bieten weitere Informationen:

  • PHP-Debugger installieren
  • PHP-Scripts debuggern
  • Debugger-Einstellungen

Verwandte Themen

  • Vorschau von PHP-Seiten


PHP-Debugger installieren

Um das PHP-Debuggen zu aktivieren, müssen Sie PHP auf Ihrem Computer installiert haben und Sie müssen die xDebug-Erweiterung zu Ihrem PHP-Setup hinzufügen. Dieses Thema führt Sie durch den Prozess.

Der schnellste und zuverlässigste Weg (für Beginner)

Um Zeit zu sparen, können Sie die automatische PHP- und xDebug-Installation verwenden. Hier klicken, um es zu laden. Nach der Installation dieses Pakets fahren Sie bitte direkt mit Schritt 4 weiter. Andernfalls geht es mit Schritt 1 weiter.

Schritt 1 - Laden und installieren von PHP

Um PHP-Scripts starten zu können, muss der PHP-Interpreter installiert sein. Besuchen Sie www.php.net und laden Sie die aktuelle Version von PHP 5.x.x (ZIP-Paket, nicht den Installer) im Windows-Binär-Bereich. Nach dem Laden der ZIP-Datei, entpacken Sie PHP in einen passenden Ordner.

Schritt 2- Laden der xDebug-Erweiterung

Gehen Sie zur Website www.xdebug.org und laden Sie xDebug-Windows-Modul für die PHP-Version, die Sie im vorherigen Schritt installiert haben. Wenn Sie beispielsweise PHP 5.1.1 installiert haben, dann brauchen Sie xDebug 5.1.1.

Schritt 3- xDebug zu PHP hinzufügen

Kopieren Sie die geladene xDebug-DLL-Datei in den Ordner, der die anderen PHP-Erweiterungen enthält, z.B. c:\php\ext\. Wenn diese erledigt ist, dann suchen und öffnen Sie die Datei php.ini. Wenn es keine solche Datei gibt, dann suchen Sie nach php.ini-dist und benennen Sie sie in php.ini um. Am Ende dieser Datei fügen Sie die folgenden Dateien ein:

[Zend] zend_extension_ts="c:\php\ext\php_xdebug.dll" xdebug.remote_enable = on

Ersetzen Sie c:\php\ext\php_xdebug.dll mit dem vollständigen Pfad zu Ihrer xDebug-DLL.

Schritt 4 - Rapid PHP konfigurieren

Klicken Sie im Optionen-Menü auf Voreinstellungen und suchen Sie die PHP-Optionen. Sie müssen den Pfad zur php.exe angeben, die sich in dem Ordner befindet, in den Sie PHP installiert haben.

Schritt 5 - Vermeiden Sie mögliche Probleme

Stellen Sie sicher, dass Rapid PHP vollständig in Ihren Firewall-Einstellungen freigegeben wurde und starten Sie das Programm erneut. Wenn Sie Rapid PHP das nächste Mal starten, dann sollten Sie Breakpoints setzen und PHP-Scripts ausführen können.


PHP-Scripts debuggen

Die folgenden Debug-Funktionen sind verfügbar.

Starten führt das aktuell geöffnete PHP-Script aus und aktiviert den Debugger.
Stopp beendet die aktuelle Debug-Sitzung.
Schritt überspringen führt Scripts zeilenweise aus, wobei Funktionen und Includes übersprungen und nur als eine Einheit angesehen werden.
Schritt hinein führt Scripts zeilenweise aus, verfolgt auch Funktionen und Includes zeilenweise.
Schritt raus springt aus der aktuell ausgeführten Funktion.
Breakpoint umkehren setzt bzw. löscht einen Zeilen-Breakpoint an der aktuellen Cursorposition.
Debugger-Einstellungen öffnet die Debugger-Einstellungen.

Hinweis

  • Die Debug-Funktionen können schnell über die Starten und Debug-Symbolleiste aufgerufen werden.

Verwandte Themen

  • PHP-Debugger installieren
  • Debugger-Einstellungen


Debugger-Einstellungen

Mit den Debugger-Einstellungen können Sie den PHP-Debugger konfigurieren.

Allgemein

Ausgabe

Legt fest, wie die Ausgabe von ausgeführten PHP-Scripts behandelt werden soll.

Parameter

Legt die URI-Parameter fest, die an das PHP-Script weitergegeben werden. Beispiel: id=1&action=edit

Debugger-Verbindung

Sessionname

xDebug-Sessionname. Das Ändern der Standardwerte wird nicht empfohlen.

An Port lauschen

Legt die TCP-Portnummer an, auf der Rapid PHP auf die xDebug-Verbindungen wartet. Wenn Sie wollen, dass xDebug mit Rapid PHP über einen anderen Port kommuniziert, dann können Sie diesen Wert ändern, müssen dann aber auch den entsprechenden xDebug-Wert in der php.ini ändern.

Verwandte Themen

  • PHP-Debugger konfigurieren


PHP-Online-Ressourcen

Voreinstellungen und Spezifikationen

  • PHP-Website
  • PHP-Online-Dokumentation

Tutorials

  • PHP Tutorial by W3Schools

Andere Ressourcen

  • PHP Builder - Artikel, Scripts und andere Ressourcen
  • HotScripts.com - Scripts und andere Ressourcen


JavaScript bearbeiten

Rapid PHP bietet einige Funktionen und Werkzeuge, die das Schreiben und Bearbeiten von JavaScript-Code effizienter machen.

JavaScript-Code schreiben

Werkzeuge in der JavaScript-Menü und Symbolleiste erlauben das Einfügen von JavaScript-Code-Teilen.

  • JavaScript-Menü und -Symbolleiste

Das AutoVervollständigen hilft beim Merken und schnellen Einfügen von Objekteigenschaften, Methoden und Ereignissen.

  • JavaScript-AutoVervollständigen verwenden

Funktionshinweise helfen beim Nachschlagen von Funktionsparametern ohne die Dokumentation verwenden zu müssen.

  • JavaScript-Funktionshinweise verwenden

Der Sprachbrowser bieten einen bequemen Weg, mit JavaScript-Objekten zu arbeiten.

  • Sprachbrowser

Navigieren durch JavaScript-Code

Sie können den <b>Code-Explorer</b> zur einfachen Navigation durch Ihren JavaScript-Code verwenden. Der Code-Explorer listet Funktionen, die in den Scripts enthalten sind und Sie können sich damit schnell durch Ihren Code bewegen.

  • Code-Explorer verwenden

Verwandte Themen

  • HTML und XHTML bearbeiten


JavaScript-Menü und -Symbolleiste

Die JavaScript-Menü/Symbolleiste erlaubt den schnellen Zugriff auf die allgemeinen JavaScript-Codefragmente und bietet Zugriff auf einige JavaScript-Werkzeuge.

JavaScript-Snippets bietet ein Auswahlmenü für das Einfügen allgemeiner JavaScript-Strukturen. Um dieses Menü zu bearbeiten, klicken Sie auf JavaScript-Snippets bearbeiten.
Funktion fügt eine JavaScript-Funktion ein.
Dokument-Schreiben fügt eine JavaScript-document.write-Anweisung ein.
Warnung fügt JavaScript-Code für die Anzeige eines Warn-Dialogs ein.
Bestätigung fügt JavaScript-Code für dei Anzeige eines Bestätigungs-Dialogs ein.


JavaScript-AutoVervollständigen verwenden

Das AutoVervollständigen hilft bei der schnellen Eingabe, indem eine Liste der gültigen Elemente und Attribute angezeigt wird, die Sie mit einem einfache Klick oder mit der Eingabe-Taste bestätigen.

Hinweise

  • Das AutoVervollständigen kann über die Voreinstellungen deaktiviert werden.
  • Die Verzögerungszeit für das Erscheinen des AutoVervollständigen-Dialogs kann in den Voreinstellungen angepasst werden.
  • Zum Schließen des AutoVervollständigen-Dialogs klicken Sie Esc.

Verwandte Themen

  • JavaScript-Code bearbeiten


JavaScript-Funktionshinweise verwenden

Funktionshinweise helfen beim Nachschlagen von JavaScript-Funktionsparametern und Beschreibungen ohne die Dokumentation verwenden zu müssen.

Funktionshinweise werden angezeigt, wenn Sie ( nach einem bekannten JavaScript-Funktionsnamen eingeben.

Alternativ können Sie den Cursor innerhalb der Klammern eines JavaScript-Funktionsaufrufs platzieren und Umschalt+Strg+Leertaste drücken, um den Hinweis bei Bedarf einzublenden.

Verwandte Themen

  • JavaScript-Code bearbeiten


Code-Explorer verwenden

Der Code-Explorer listet Funktionen, die in Scripts enthalten sind und Sie können sich damit schnell durch sie bewegen. Sie können zu einem Eintrag navigieren, indem Sie auf ihn klicken.

Um den Code-Explorer zu aktivieren, klicken Sie im Menü Ansicht auf Code-Explorer. Stellen Sie sicher, dass die <b>JavaScript</b>-Option im unteren Teil der Code-Explorer-Leiste aktiviert ist.

Der Code-Explorer aktualisiert sich automatisch, wenn Sie mit der Maus darüber fahren, aber Sie können die Aktualisierung auch jederzeit manuell aktivieren, indem Sie auf die <b>Aktualisieren</b>-Schaltfläche klicken.

Verwandte Themen

  • JavaScript-Code bearbeiten


JavaScript-Online-Ressourcen

Voreinstellungen und Spezifikationen

  • JavaScript Reference by DevGuru

Tutorials

  • JavaScript Tutorial by W3Schools

Andere Ressourcen

  • HotScripts.com - Scripts und andere Ressourcen
  • JavaScript-Beispiele und Tipps


Sprachbrowser

Der Sprachbrowser bietet Hilfe bei den Scripting-Sprachen wie JavaScript, ASP und PHP und Markup-Sprachen wie HTML und WML.

Um den Sprachbrowser zu aktivieren, klicken Sie im Ansicht-Menü auf Sprachbrowser. Wählen Sie dann die Sprache aus dem Menü im oberen Teil des Dialogs aus.

Scripting-Sprachen

Je nach gewählter Sprache, listet der Sprachbrowser alle Objektklassen, deren Eigenschaften, Methoden und Ereignisse. Sie können Sie direkt in Ihren Code durch Ziehen oder Doppelklick einfügen.

Markup-Sprachen

Je nach gewählter Sprache, listet der Sprachbrowser alle Tags und deren Eigenschaften. Sie können Sie direkt in Ihren Code durch Ziehen oder Doppelklick einfügen.


SQL-Explorer

Mit dem SQL-Explorer durchsuchen Sie schnell Datenbanken und Tabellenstrukturen.

Um den SQL-Explorer zu aktivieren, klicken Sie im Menü Ansicht auf SQL-Explorer.

Um eine Datenbankverbindung aufzubauen, klicken Sie auf die Schaltfläche Neue Datenbankverbindung [image] in der Symbolleiste. Wenn die Datenbankverbindung hinzugefügt wurde, können Sie die Verbindung mit einem Doppelklick aufbauen.

Sie können Datenbanknamen, Tabellennamen oder Feldnamen direkt in Ihren Code ziehen. Durch gedrückthalten der Umschalt-Taste beim Ziehen des Feldnamens werden der Feld- und der Tabellenname table.field eingefügt.

Um Tabellendaten zu durchsuchen oder SQL-Befehle auszuführen, wählen Sie die Datenbank oder Tabelle und klicken Sie auf SQL-Browser [image] in der Symbolleiste.

Hinweise

  • Derzeit werden MySQL-, PostgreSQL- und Firebird SQL-Datenbanken unterstützt.
  • Zur Nutzung der Funktion müssen Sie gegebenenfalls spezielle Datenbank-Treiber installieren. Klicken Sie hier für weitere Informationen.


HTML-Tag-Hervorhebung

Die HTML-Tag-Hervorhebung markiert das Tag-Paar des aktuellen Markup-Blocks mit einem grünen Hintergrund.

Tags werden nur hervorgehoben, wenn gemäß den aktuellen HTML-Spezifikationen ein entsprechendes schließendes Tag vorhanden ist.
Fehlende oder überflüssige Tags innerhalb des markierten Tags werden mit einer roten Hintergrundfarbe markiert.

Um die Funktion an- oder abzuschalten...

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen.
  2. Klicken Sie im Voreinstellungen-Dialog auf den Ordner Texteditor.
  3. Klicken Sie auf Ansicht.
  4. Aktivieren/deaktivieren Sie die Option Passende und fehlende HTML-Tags hervorheben.
  5. Klicken Sie auf OK.


Klammernhervorhebung

Die Klammernhervorhebung markiert das Klammernpaar in der Nähe des Cursors.

Um die Funktion an- oder abzuschalten...

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen.
  2. Klicken Sie im Voreinstellungen-Dialog auf den Ordner Texteditor.
  3. Klicken Sie auf Allgemein.
  4. Aktivieren/deaktivieren Sie die Option Klammernhervorhebung.
  5. Klicken Sie auf OK.


Code-Faltung

Mit der Code-Faltung können Sie unwichtige Codeteile zur besseren Übersicht und Navigation verbergen. Es gibt zwei Code-Faltungs-Methoden:

  • Code-Faltung der Auswahl.
  • Code-Faltung für Code.

Verwenden der Code-Faltung der Auswahl

  • Zum Aktivieren klicken Sie im Optionen-Menü auf Code-Faltung der Auswahl.
  • Wählen Sie den Text, der eingeklappt werden soll. Verwenden Sie die Symbole "+" und "-" im Randbereich, um Textblöcke ein- und auszuklappen.

Verwenden der Code-Faltung für Code

  • Zum Aktivieren klicken Sie im Optionen-Menü auf Code-Faltung für Code.
  • Wenn der aktuelle Dokumententyp die Code-Faltung für Code unterstützt, dann können Sie Codeblöcke mit "+" und "-" ein- und ausklappen.

Hinweise

  • Nur eine der Code-Faltungs-Methoden kann zur gleichen Zeit verwendet werden.
  • Der Code-Faltungs-Zustand wird beim Schließen einer Datei gespeichert.
  • Um schnell den eingefalteten Code einsehen zu können, platzieren Sie die Maus über dem Faltungszeichen im Code-Editor.


Deklaration suchen-Befehl

Mit dem Deklaration suchen-Befehl können Sie schnell nach der Deklaration oder dem ersten Auftreten von Variablen, Funktion oder Klassen suchen. Derzeit gibt es diese Funktion nur für PHP.

Um den Deklaration suchen-Befehl auszuführen, Rechtsklicken Sie auf das Code-Objekt und wählen Sie Deklaration suchen im Kontextmenü.


Tutorial: Konfigurieren der PHP-Vorschau

Um PHP-Dateien lokal, ohne Hochladen auf das Web, in einer Vorschau sehen zu können, müssen Sie einen Webserver auf Ihrem Computer installiert haben und er muss konfiguriert sein, PHP-Dateien zu unterstützen. Bitte konsultieren Sie die PHP- oder die Webserver-Anleitung für weitere Informationen für die Installation des Webservers mit PHP-Support.

Wir empfehlen die Verwendung des kostenlosen Apache Webservers von apache.org

Schritt 1 - Welches ist das Root für Web-Dokumente?
Finden Sie heraus, welches Ihr lokales Webserver-Dokumenten-Root ist. Dieser Dokumenten-Root-Ordner speichert die Dateien, die Ihr Webserver über die URL abrufen kann. Bitte konsultieren Sie die Anleitung Ihres Webservers für weitere Informationen.

Schritt 2 - Welches ist Ihre Webserver-Adresse?
Finden Sie heraus, welches die lokale Webserver-URL ist, normalerweise ist dies http://localhost/

Schritt 3 - Stellen Sie sicher, dass Ihr Webserver läuft
Stellen Sie sicher, dass Ihr Webserver wirklich mit PHP-Dateien zusammenarbeitet. Um dies zu testen, können Sie eine PHP-Datei in Ihr Webserver-Root kopieren und sie über den Webbrowser öffnen. Beispiel: Wenn Ihr Webserver-Root c:\htdocs\ ist, dann speichern Sie die Datei als c:\htdocs\index.php und versuchen Sie sie mit der URL http://localhost/index.php zu öffnen.

Wenn Ihr Webserver läuft, sind Sie nur bereit, die Vorschau zu konfigurieren.

Schritt 4 - Vorschau konfigurieren
Nun müssen Sie dem Editor mitteilen, wie Ihr Webserver zur Anzeige von PHP-Vorschaudateien verwendet werden kann.

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen;
  2. Im Voreinstellungen-Dialog klicken Sie auf den Vorschau-Ordner;
  3. Klicken Sie auf Zuordnungen, dann auf Hinzufügen;
  4. Geben Sie Ihr Dokumenten-Root-Ordner und die entsprechende Webadresse ein, gemäß obigem Beispiel wäre dies c:\htdocs\ und http://localhost/.


Vorschau der Server Side Scripts

Server Side Scripts wie PHP oder ASP müssen auf dem Webserver ausgeführt werden, bevor eine Vorschau erzeugt werden kann. Rapid PHP bieten eine Funktion namens Zuordnungen, die Scripts für die Vorschau an den Webserver weiterleitet.

Zuordnungen erlauben das Zuordnen Ihres lokalen Dateisystems oder FTP-Ordners zu Ihren Webadressen. Beispielsweise können Sie c:\wwwroot der URL http://localhost/ zuordnen.

Um Zuordnungen hinzuzufügen, zu bearbeiten oder zu entfernen:

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen.
  2. In den Voreinstellungen klicken Sie auf den Vorschau-Ordner.
  3. Klicken Sie auf Zuordnungen.
  4. Klicken Sie auf Hinzufügen, Löschen oder Bearbeiten, um Zuordnungen zu bearbeiten.

Hinweis

  • Sie müssen einen Webserver auf Ihrem Computer installiert haben, um Server Side Scripts in der Vorschau zu sehen, ohne Sie ins Web hochladen zu müssen. Und Ihr Webserver muss so konfiguriert sein, dass er solche Scripts ausführen kann.


Vorschau in einem Webbrowser

Um ein Dokument in der Webbrowser-Vorschau anzuzeigen...

  • Klicken Sie im Werkzeuge-Menü auf Vorschau in.
  • Klicken Sie im Vorschau in-Untermenü auf den Webbrowser, den Sie verwenden wollen.

Verwandte Themen

  • Interne Vorschau
  • Webbrowser konfigurieren


Vorschau im Dokumentfenster

Um die Datei im gleichen Dokumentenfenster in der Vorschau ansehen zu können, klicken Sie auf die Vorschau-Registerkarte am Ende des Dokumentfensters.

Verwandte Themen

  • Interne Vorschau
  • Vorschau-Symbolleiste verwenden


Interne Vorschau

Die interne Vorschau erlaubt die Vorschau von Dokumenten ohne die Editor-Umgebung zu verlassen.

Um die interne Vorschau zu aktivieren, klicken Sie auf Vorschau am Ende des Dokumentenfensters.

Sie können auch eine der Registerkarten Vertikal/Horizontal teilen am unteren Rand des Dokumentenfensters verwenden, um den Seitencode und die Vorschau gleichzeitig zu sehen.

Hinweise

  • Die interne Vorschau kann mit der Vorschau-Symbolleiste angepasst werden. Um die Symbolleiste anzuzeigen oder zu verbergen, klicken Sie im Ansicht-Menü auf Vorschau-Symbolleiste.
  • Manchmal kann bei der Vorschau eines Webdokuments ein Lineal hilfreich sein. Um das Lineal anzuzeigen oder zu verbergen, klicken Sie im Ansicht-Menü auf Vorschau-Lineale.

Verwandte Themen

  • Vorschau-Symbolleiste verwenden
  • Vorschau in eimem Webbrowser


Vorschau-Symbolleiste verwenden

Mit der Vorschau-Symbolleiste können Sie die interne Vorschau anpassen.

Um die Symbolleiste anzuzeigen oder zu verbergen, klicken Sie im Ansicht-Menü auf Vorschau-Symbolleiste.

Vorschau-Symbolleiste-Befehle

Vorschaudatei gibt die Datei oder Adresse an, die für die Erzeugung der Vorschau verwendet werden soll.
 | Vorschaudatei öffnen erlaubt das Hinzufügen einer Vorschaudatei. Dieser Befehl wird verwendet, um eine HTML-Datei für die Vorschau eines Stylesheets auszuwählen.
 | Vorschau aktualisieren aktualisiert die interne Vorschau. Diese Funktion wird verwendet, wenn sich die Datei nach der Erstellung der Vorschau geändert wurde.
 | Lineale anzeigen zeigt oder verbirgt das Lineal in der internen Vorschau. Lineale helfen beim Bestimmen der Breite und Höhe von Elementen von Webseiten.
 | Vorschau schließen schließt die Vorschau und Macht das Gleiche wie ein Klick auf die Code-Editor-Registerkarte unten im Dokumentfenster.

Verwandte Themen

  • Interne Vorschau


Webbrowser konfigurieren

Sie können die Webbrowser, die Rapid PHP für die Vorschau von Dateien verwendet, hinzufügen oder entfernen.

Um den Webbrowser zu konfigurieren...

  • Klicken Sie im Optionen-Menü auf Voreinstellungen.
  • In den Voreinstellungen klicken Sie auf den Vorschau-Ordner.
  • Klicken Sie auf Browser.

Hinweise

  • Auch wenn Rapid PHP einige Browser automatisch erkennen kann, so funktioniert dies nicht mit allen Browsern und deren Versionen.

Verwandte Themen

  • Vorschau in eimem Webbrowser


Wiederverwendung von Code

Beim Schreiben von Code, sei es für eine Webseite, ein Stylesheet oder ein Script, verwendet man oft die gleiche oder ähnliche Strukturen oder Code-Fragmente. Sie können daher viel Zeit sparen, wenn Sie den einmal geschriebenen Code wiederverwenden.

In Rapid PHP gibt es mehrere Funktionen, die Ihnen bei der Wiederverwendung von Code helfen. Die Bibliothek erlaubt das Speichern und Wiederverwenden von Code-Snippets, während Vorlagen das schnelle Ableiten eines neuen Dokuments von einem existierenden ermöglichen.

Die folgenden Themen bieten weitere Informationen:

  • Vorlagen
  • Bibliothek


Vorlagen (Templates)

Eine Vorlage ist eine Datei, die eine Struktur enthält, von der eine neue Datei abgeleitet werden kann. Vorlagen helfen dabei, neue Dokumente schneller zu erstellen. In den meisten Fällen ist ein neues Dokument schneller erstellt, wenn man ein existierendes nimmt und Inhalt hinzufügt, anstatt es von Grund auf neu zu erstellen.

Rapid PHP enthält einige Vorlagen, aber Sie können auch eigene hinzufügen.

Die folgenden Themen bieten weitere Informationen:

  • Datei aus Vorlage erstellen
  • Vorlagen hinzufügen


Datei aus einer Vorlage erstellen

Um eine neue Datei aus einer Vorlage zu erstellen...

  1. Klicken Sie im Datei-Menü auf Neu aus Vorlage.
  2. Im Neu aus Vorlage-Dialog können Sie die Vorlage über die Registerkarten aussuchen.
  3. Markieren Sie die gewünschte Vorlage mit einem einfachen Klick.
  4. Klicken Sie auf OK.

Verwandte Themen

  • Vorlagen
  • Vorlagen hinzufügen


Vorlage hinzufügen

Um Ihre eigene Vorlage hinzuzufügen...

  1. Öffnen Sie die Datei, die Sie als Vorlage verwenden wollen.
  2. Klicken Sie im Datei-Menü auf Als Vorlage speichern. Im Speicherdialog wird der aktuelle Rapid PHP-Vorlagen-Ordner geöffnet.
  3. Wählen Sie ein bestehendes Unterverzeichnis oder erstellen Sie Ihr eigenes Unterverzeichnis.
  4. Geben Sie den Dateinamen ein und klicken Sie auf OK.

Verwandte Themen

  • Vorlagen
  • Datei aus Vorlage erstellen


Abfrage-Tokens

Abfrage-Tokens sind spezielle Codes, mit denen ein Snippet eine Benutzereingabe anfordern kann.

Syntax

Abfrage-Tokens haben eine der folgenden Formen:

%[Prompt message]%
%[Prompt message]=[default value]%

Letzterer öffnet den folgenden Dialog:

Abfrage-Tokens, die den gleichen Nachfragenamen haben ("SomeName" im unteren Beispiel), fragen nur beim ersten Mal nach einem Eingabewert. Die anderen Tokens erhalten ihren Wert vom ersten. Siehe Beispiele für eine Beispiel.

%[SomeName]% ..text.. %[SomeName]%

Beispiele

1) Das folgende Snippet erlaubt das Einfügen eines benutzerdefinierten Hyperlinks:

<a href="%[URL eingeben:]%">%[Linktext eingeben:]=[Hello!]%</a>

Wenn Sie dieses Snippet einfügen, erhalten Sie folgende Eingabeaufforderungen URL eingeben und Linktext eingeben.

2) Das folgende Snippet erlaubt die Abfrage einer Option:

<option value="%[ID eingeben]%">%[ID eingeben]%</option>

Wenn Sie dieses Snippet einfügen, erhalten Sie die Aufforderung ID eingeben nur ein Mal und der Wert für das zweite Abfrage-Token wird von der ersten Eingabe übernommen.

Verwandte Themen

  • Bibliothek


Bibliothek

Die Bibliothek erlaubt es, Codestücke abzuspeichern und diese später einfach wiederzuverwenden.

Die Bibliothek ist eine andockbare Anzeige, die Ordner und Code-Snippets enthält. Die Bibliothek erlaubt Ihnen das Abspeichern einer unbegrenzten Anzahl von Code-Snippets, die in einer unbegrenzten Anzahl von Ordnern abgelegt werden können.

Rapid PHP enthält nach der Installation bereits einige nützliche Code-Fragmente in der Bibliothek. Diese sollten Sie sich einmal ansehen.

Um die Bibliotheks-Anzeige anzuzeigen oder zu verbergen, klicken Sie im Ansicht-Menü auf Bibliothek.

Die folgenden Themen bieten weitere Informationen:

  • Code von der Bibliothek einfügen
  • Code zur Bibliothek hinzufügen


Code von der Bibliothek einfügen

Um die Bibliothek verwenden zu können, müssen Sie sicherstellen, das die Bibliotheks-Liste geöffnet ist. Wenn nicht, dann klicken Sie im Ansicht-Menü auf Bibliothek.

Das Einfügen eines Snippets aus der Bibliothek in Ihr Dokument ist einfach und kann auf zwei Arten durchgeführt werden:

  • Platzieren Sie den Cursor an der Stelle, an der der Snippet-Code eingefügt werden soll und doppelklicken Sie dann das gewünschte Snippet in der Bibliothek.
  • Ziehen Sie das Snippet aus der Bibliothek an die gewünschte Stelle in Ihrem Dokument, um es dort einzufügen.

Wenn Sie dem Snippet ein Tastenkürzel zugewiesen haben, drücken Sie einfach diese Tastenkombination. Die Bibliothek muss in diesem Fall nicht sichtbar sein.

Verwandte Themen

  • Bibliothek
  • Code zur Bibliothek hinzufügen


Code zur Bibliothek hinzufügen

Um ein Code-Snippet zur Bibliothek hinzuzufügen...

  1. Klicken Sie im Optionen-Menü auf Bibliothek-Editor.
  2. Wählen Sie einen der vorhandenen Ordner oder verwenden Sie Neuer Ordner oder Unterordner, um einen neuen Ordner zu erstellen.
  3. Klicken Sie auf Neues Snippet.
  4. Der Snippet-Editor erscheint. Geben Sie im Name-Feld den Titel des Snippets ein. Dann geben Sie den Inhalt des Snippets im Textfeld ein.
  5. Klicken Sie OK, um das Code-Snippet zu speichern.
  6. Klicken Sie auf Schließen, um den Bibliothek-Editor zu verlassen.

Verwandte Themen

  • Bibliothek
  • Code von der Bibliothek einfügen
  • Abfrage-Tokens


Code-Vorlagen

Code-Vorlagen sind Codestücke, die Sie einfach mit ein paar Tastendrücken einfügen können. Code-Vorlagen sind eigentlich Code-Snippets aus der Bibliothek, die ein zugewiesenes Aufrufwort haben. Ein Aufrufwort ist eine Abkürzung, mit der Sie die damit verbundene Code-Vorlage aufrufen können.

Die folgenden Themen bieten weitere Informationen:

  • Code-Vorlagen einfügen
  • Code-Vorlage erstellen


Code-Vorlagen einfügen

Das Einfügen einer Code-Vorlage ist einfach und kann auf zwei Arten durchgeführt werden:

  • Durch Verwendung des Tastenkürzels Strg+J, die den Code-Vorlagen-Dialog öffnet, in dem Sie die Code-Vorlage auswählen können.
  • Durch Eingabe des Aufrufworts, das mit der gewünschten Code-Vorlage verbunden ist und nachfolgendem drücken von Strg+J wird das Aufrufwort durch die verbundene Code-Vorlage ersetzt.

Hinweis

Wenn nach dem Drücken von Strg+J kein Dialog erscheint, dann bedeutet dies, dass die Bibliothek kein mit dem Aufrufwort verbundenes Snippet enthält.

Nach einiger Zeit können sich große Mengen von Snippets ansammeln. Wenn Sie mit mehr als einer Programmiersprache arbeiten, dann ist es empfehlenswert, die Code-Vorlagen dadurch zu gruppieren, dass man den Aufrufwörtern ein Prefix gibt. Beispielsweise könnte ein PHP-Snippet, da einen IF-ELSE-Block ausgibt, das Aufrufwort "phpife" erhalten.

Verwandte Themen

  • Code-Vorlage erstellen


Code-Vorlage erstellen

  1. Klicken Sie im Optionen-Menü auf Bibliothek-Editor.
  2. Wählen Sie einen der vorhandenen Ordner oder verwenden Sie Neuer Ordner oder Unterordner, um einen neuen Ordner zu erstellen.
  3. Klicken Sie auf Neues Snippet.
  4. Der Snippet-Editor erscheint. Geben Sie im Name-Feld den Titel des Snippets ein. Dann geben Sie den Inhalt des Snippets im Textfeld ein.
  5. Geben Sie im Name-Feld den Titel des Snippets ein. Dann geben Sie den Inhalt des Snippets im Textfeld ein.
  6. Geben Sie im Aufrufwort-Feld ein eindeutiges Aufrufwort für die Code-Vorlage ein. Nur Snippets mit einem zugewiesenen Aufrufwort werden als Code-Vorlagen behandelt.
  7. Klicken Sie auf OK, um das Code-Snippet (Vorlage) zu speichern.
  8. Klicken Sie auf Schließen, um den Bibliothek-Editor zu verlassen.

Verwandte Themen

  • Code von Bibliothek einfügen


Code-Präprozessor

Der Code-Präprozessor erlaubt die Verwendung von dynamischem Inhalt in normalen HTML-Dateien. Diese Elemente werden bei jedem Speichern der Datei aktualisiert.

Sie können beispielsweise das Datum einfügen und es wird immer beim Speichern der Datei automatisch aktualisiert.

Derzeit unterstützte Elemente

Datum [Date stamp]

Syntax:
<!--%DateStamp%--><!---->

Beispiel:
<!--%DateStamp%-->2008.04.11.<!---->

Uhrzeit [Time stamp]

Syntax:
<!--%TimeStamp%--><!---->

Beispiel:
<!--%TimeStamp%-->2008.04.11.<!---->

Datei einfügen [File include]

Syntax:
<!--%IncFile filepath%-->
<!---->

Beispiel:
<!--%IncFile c:\my web\header.htm%-->
<!---->

Hinweise

  • Um schnell das Datum oder die Uhrzeit einzufügen, klicken Sie im Einfügen-Menü auf Date Stamp oder Time Stamp.
  • Datei-Includes können relative Pfade verwenden, allerdings wird dies bei FTP-basierten Dateien nicht unterstützt.


Tastenkürzel anpassen

Sie können die Tastenkürzel für Menübefehle anpassen.

Um Tastenkürzel zu erstellen oder zu ändern...

  1. Klicken Sie im Optionen-Menü auf Tastenkürzel.
  2. Im Tastenkürzel-Dialog wählen Sie einen Befehl und klicken auf Tastenkürzel zuweisen.
  3. Wählen Sie das gewünschte Tastenkürzel und klicken Sie auf OK.
  4. Klicken Sie auf Schließen um den Tastenkürzel-Dialog zu beenden.


Oberflächenstil ändern

Wenn Ihnen der Standardstil der Oberfläche nicht gefällt, können Sie ihn einfach wechseln.

Um den Oberflächenstil zu ändern...

  1. Klicken Sie im Ansicht-Menü auf Oberflächenstil.
  2. Wählen Sie einen der verfügbaren Stile.

Verwandte Themen

  • Symbolleisten anpassen


Texteditor anpassen

Der Texteditor ist sehr flexibel. Sie können verschiedene Eigenschaften des Texteditors an Ihre Bedürfnisse und Ihren Arbeitsweise anpassen.

Um den Texteditor anzupassen...

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen.
  2. Klicken Sie im Voreinstellungen-Dialog auf den Ordner Texteditor.
  3. Stellen Sie die Optionen wie gewünscht ein.

Der Voreinstellungen-Dialog bietet verschiedene Seiten für die Konfiguration des Texteditors.

Allgemeine Aufgaben

  • Textfarben ändern
  • Zeilennummern umschalten
  • Zeilenumbruch umschalten
  • Versteckte Zeichen umschalten


Textfarben ändern

Sie können die Farben der Syntaxhervorhebung ändern.

Um die Textfarben zu ändern...

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen.
  2. Klicken Sie im Voreinstellungen-Dialog auf den Ordner Texteditor.
  3. Klicken Sie auf Farben.
  4. Im Bereich Sprache wählen Sie die Sprache und die Elemente, deren Farbe Sie ändern wollen.
  5. Wählen Sie Vordergrund- und Hintergrund-Farbe und Textattribute.
  6. Wiederholen Sie die letzten zwei Schritte für jede Sprache und jedes Element, dessen Farbe Sie ändern wollen.
  7. Klicken Sie auf OK.

Verwandte Themen

  • Texteditor anpassen


Zeilennummern umschalten

Sie können die Zeilennummern aktivieren oder deaktivieren.

Um die Zeilennummernoption zu ändern...

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen.
  2. Klicken Sie im Voreinstellungen-Dialog auf den Ordner Texteditor.
  3. Klicken Sie auf Allgemein.
  4. Zeilennummern umschalten:
    • Um Zeilennummern anzuzeigen, markieren Sie Bundsteg anzeigen und Zeilennummern auf dem Bundsteg.
    • Um die Zeilennummern zu verbergen, entfernen Sie das Häkchen bei Zeilennummern im Bundsteg anzeigen. Um den Bundsteg zu verbergen, entfernen Sie das Häkchen bei Bundsteg anzeigen.
  5. Klicken Sie auf OK.

Verwandte Themen

  • Texteditor anpassen


Zeilenumbruch umschalten

Um den Zeilenumbruch umzuschalten...

  1. Klicken Sie im Optionen-Menü auf Zeilenumbruch.

Verwandte Themen

  • Texteditor anpassen


Versteckte Zeichen umschalten

Um versteckte Zeichen umzuschalten...

  1. Klicken Sie im Optionen-Menü auf Versteckte Zeichen anzeigen.

Verwandte Themen

  • Texteditor anpassen


Sprache der Rechtschreibprüfung ändern

Um die Sprache der Rechtschreibprüfung zu ändern...

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen.
  2. Klicken Sie im Voreinstellungen-Dialog auf Rechtschreibprüfung.
  3. Klicken Sie auf Rechtschreibprüfung konfigurieren.
  4. Wählen Sie ein Wörterbuch oder klicken Sie auf Wörterbücher suchen, um ein neues hinzuzufügen.
  5. Klicken Sie auf OK.

Note

  • Sie können weitere Wörterbücher von unserer Website herunterladen. Sie können mit dem oben beschriebenen Verfahren hinzugefügt werden.

Verwandte Themen

  • Rechtschreibung prüfen


Symbolleisten anpassen

Symbolleisten und Menüs können vollständig angepasst werden. Sie können Symbolleisten verschieben, anzeigen und verbergen. Sie können sogar Symbolleisten und Menüeinträge hinzufügen und entfernen und vieles mehr.

Um eine Symbolleiste anzuzeigen oder zu verbergen...

  1. Rechtsklicken Sie auf eine beliebige Symbolleiste oder die Hauptmenüleiste.
  2. Klicken Sie auf den Namen der Symbolleiste.

Um eine Schaltfläche einer Symbolleiste anzuzeigen oder zu verbergen...

  1. Klicken Sie auf den Pfeil am rechten Ende der Symboleiste.
  2. Klicken Sie auf Schaltfläche hinzufügen oder entfernen.
  3. Klicken Sie auf den Namen einer Schaltfläche.

Um Symbolleisten oder Menüseinträge anzupassen...

  1. Rechtsklicken Sie auf eine beliebige Symbolleiste oder die Hauptmenüleiste.
  2. Klicken Sie auf Anpassen
  3. Öffnen Sie das Befehle-Register.
  4. Sie können nun einen Eintrag aus der Liste der Befehle auf jede Symboleiste oder ein Menü ziehen. Entfernen Sie Einträge, indem Sie sie aus der Symbolleiste oder dem Menü herausziehen.
  5. Schließen Sie das Anpassen-Fenster, um die Anpassung zu beenden.

Verwandte Themen

  • Leisten anpassen
  • Mit Layouts arbeiten
  • Oberflächenstil ändern


Leisten anpassen

Leisten sind andockbare Fenster, die im Hauptfenster frei schwebend abgelegt werden können oder an dessen Seiten andocken können. Sie können Leisten verschieben, anzeigen und verbergen. Sie können die Position einer Leiste durch Ziehen und Andocken verändern.

Um eine Leiste neu anzuordnen, klicken Sie auf deren Titelleiste und ziehen Sie es an die gewünschte Stelle.

Um eine Leiste zu verbergen, klicken Sie auf deren Schließen-Feld (x).

Um eine Leiste anzuzeigen, klicken Sie im Ansicht-Menü auf deren Namen.

Verwandte Themen

  • Symbolleisten anpassen
  • Mit Layouts arbeiten


Mit Layouts arbeiten

Layouts sind eine Kombination von Symbolleisten, Leistenpositionen und Konfigurationen. Sie können Ihr bevorzugtes Layout schnell laden und speichern.

Um ein Layout zu speichern...

  1. Klicken sie im Ansicht-Menü auf Layout speichern.
  2. Geben Sie einen Namen für das Layout ein und klicken Sie auf OK.

Um ein Layout zu laden...

  1. Klicken Sie im Ansicht-Menü auf Layouts verwalten.
  2. Wählen Sie ein Layout und klicken Sie auf Aktivieren.

Um ein Layout zu löschen...

  1. Klicken Sie im Ansicht-Menü auf Layouts verwalten.
  2. Wählen Sie den Namen des Layouts und klicken Sie auf Löschen.

Note

  • Sie können Layouts auch mit dem Layout [image] -Schalter in der Symbolleiste umschalten.

Verwandte Themen

  • Symbolleisten anpassen
  • Leisten anpassen


HTML-Spezifikation

Die HTML-Spezifikation ist eine Option, die Rapid PHP vermittelt, welche HTML-Spezifikationen für die Erstellung von Code mit dem Inspektor oder dem AutoVervollständigen verwendet werden sollen.

Wenn Sie beispielsweise XHTML 1.0-kompatiblen Code erstellen wollen, dann müssen Sie die XHTML 1.0-Definition aktivieren.

Um die Standard-HTML-Spezifikation zu ändern...

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen.
  2. Klicken Sie in den Voreinstellungen auf den Ordner Sprachoptionen.
  3. Klicken Sie auf HTML.
  4. Wählen Sie mit dem Auswahlfeld die HTML-Sprachdefinition.
  5. Klicken Sie auf OK.

Hinweis

  • Standardmäßig verwendet Rapid PHP automatisch die HTML-Spezifikation, die im DOCTYPE-Tag des aktuellen Dokuments eingetragen ist und die Standard-HTML-Spezifikation wird nur verwendet, wenn kein gültiges DOCTYPE-Tag vorhanden ist. Sie können dieses Verhalten in den Voreinstellungen neben dem HTML-Sprachspezifikation-Feld ändern.


CSS-Spezifikation

Die CSS-Spezifikation ist eine Option, die Rapid PHP vermittelt, welche CSS-Spezifikationen für die Erstellung von Code mit dem Inspektor oder dem AutoVervollständigen verwendet werden sollen.

Wenn Sie beispielsweise CSS Level 2-kompatiblen Code erstellen wollen, dann müssen Sie die CSS Level 2-Definition aktivieren.

Um die aktive CSS-Definition zu ändern...

  1. Klicken Sie im Optionen-Menü auf Voreinstellungen.
  2. Klicken Sie in den Voreinstellungen auf den Ordner Sprachoptionen.
  3. Klicken Sie auf CSS.
  4. Wählen Sie mit dem Auswahlfeld die CSS-Sprachdefinition.
  5. Klicken Sie auf OK.


Online-Ressourcen

Blumentals Software bietet verschiedene Online-Ressourcen und Supportoptionen.

  • Blumentals Software
  • Kundensupport-Website
  • Supportforum


Probleme melden

Bitte schauen Sie zuerst auf unseren Online Supportseiten vorbei!

Bitte geben Sie uns zumindest folgende Informationen bei einem Fehlerreport

  • Die Version Ihres Programms. Sie finden sie im Info-Dialog im Hilfe-Menü.
  • Die Version des Windows-Systems, das Sie verwenden.
  • Informationen, wie man das Problem reproduzieren kann.
  • Eine detaillierte Beschreibung des Problems.

Senden Sie den Report an: support@blumentals.net


Farbwähler-Dialog

Der Farbwähler-Dialog erlaubt das Auswählen von HTML- und CSS-Farbwerten.

Palette

Die aktuell gewählte Farbpalette. Die Farben der Palette werden in einem Farbraster angezeigt.

Wert

Enthält den Hexadezimal-Wert der gewählten Farbe.

Name

Zeigt den Namen der gewählten Farbe (falls vorhanden).

Benutzerdefiniert

Zeigt den Standard-Farbdialog zur Auswahl einer Farbe.

Auswählen

Erlaubt das Entnehmen eine beliebigen Farbe von einem Screen.


Registrierformular

Registrierformular für Rapid PHP 2010

Programm-Nr.: 300002722

Kundeninformation

Nachname: __________________________________

Vorname: __________________________________

Firma: ___________________________________

Straße und Nr.: ________________________________

Stadt, Bundesland, PLZ: _______________________

Land: _____________________________

Telefon: _______________________________

Fax: _________________________________

E-Mail: _______________________________

*** Bitte vergessen Sie nicht Ihre Mailadresse.
Wir werden die Mailadresse für den Kontakt mit Ihnen verwenden.

Wie wollen Sie den Registrierschlüssel erhalten?

E-Mail
Fax
Post

Wie wollen Sie den Betrag bezahlen:

Kreditkarte
Überweisung
Scheck
Barzahlung

Kreditkarteninformation (falls vorhanden)

Kreditkarte:

Visa
Eurocard/Mastercard
American Express
Diners Club

Kreditkartenhalter: _________________________

Kreditkarten-Nr.: ___________________________

Ablaufdatum: ______________

Datum / Unterschrift: ______________________


Registrierformular

Registrierformular für die Rapid PHP 2010 Privatlizenz

Programm-Nr.: 300009198

Kundeninformation

Nachname: __________________________________

Vorname: __________________________________

Firma: ___________________________________

Straße und Nr.: ________________________________

Stadt, Bundesland, PLZ: _______________________

Land: _____________________________

Telefon: _______________________________

Fax: _________________________________

E-Mail: _______________________________

*** Bitte vergessen Sie nicht Ihre Mailadresse.
Wir werden die Mailadresse für den Kontakt mit Ihnen verwenden.

Wie wollen Sie den Registrierschlüssel erhalten?

E-Mail
Fax
Post

Wie wollen Sie den Betrag bezahlen:

Kreditkarte
Überweisung
Scheck
Barzahlung

Kreditkarteninformation (falls vorhanden)

Kreditkarte:

Visa
Eurocard/Mastercard
American Express
Diners Club

Kreditkartenhalter: _________________________

Kreditkarten-Nr.: ___________________________

Ablaufdatum: ______________

Datum / Unterschrift: ______________________


ASP bearbeiten

Rapid PHP bietet spezielle Funktionen für die Bearbeitung von ASP.

ASP-Menü und -Symbolleiste

Mit der ASP-Menü und -Symbolleiste können Sie schnell die allgemeinen ASP-Codefragmente einfügen.

ASP-Snippets bieten ein Auswahlmenü für das Einfügen allgemeiner ASP-Strukturen. Um dieses Menü zu bearbeiten, klicken Sie auf ASP-Snippets bearbeiten.
ASP-Servervariable zeigt eine Liste der Servervariablen. Um ein Element einzufügen, markieren Sie es und klicken auf OK.
ASP-Tag fügt ASP-Tags <% %> ein.
ASP-Block fügt die ASP-Tags <% und %> in separate Zeilen ein und erstellt damit einen mehrzeiligen ASP-Codeblock.
ASP-Ausgabe-Tag fügt die ASP-Ausgabe-Tags <%= %> ein.
Datei einfügen fügt die Include-Tags für eine Datei ein.
Virtuellen Pfad einfügen fügt die virtuellen Include-Tags ein.

Sprachbrowser

Der Sprachbrowser bietet einen bequemen Weg, mit ASP-Objekten zu arbeiten.

  • Sprachbrowser


Scripts bearbeiten

Rapid PHP bietet eine bequeme Umgebung für die Arbeit mit JavaScript, ASP, PHP, SSI und Perl-Scripts. Die Syntaxhervorhebung ist für alle diese Sprachen verfügbar und zudem gibt es noch einige spezielle Werkzeuge.

Die folgenden Themen bieten weitere Informationen:

  • JavaScript bearbeiten
  • ASP bearbeiten
  • PHP bearbeiten
  • SSI bearbeiten
  • Vorschau der Server Side Scripts


JavaScript bearbeiten

Rapid PHP bietet einige spezielle Funktionen für die Bearbeitung von JavaScript.

JavaScript-Menü und -Symbolleiste

Mit der JavaScript-Menü und -Symbolleiste können Sie schnell die allgemeinen JavaScript-Strukturen einfügen.

JavaScript-Snippets bietet ein Auswahlmenü für das Einfügen allgemeiner JavaScript-Strukturen. Um dieses Menü zu bearbeiten, klicken Sie auf JavaScript-Snippets bearbeiten.
Funktion fügt eine JavaScript-Funktion ein.
Dokument-Schreiben fügt eine JavaScript-document.write-Anweisung ein.
Warnung fügt JavaScript-Code für die Anzeige eines Warnungs-Dialogs ein.
Bestätigung fügt JavaScript-Code für dei Anzeige eines Bestätigungs-Dialogs ein.

Sprachbrowser

Der Sprachbrowser bietet einen bequemen Weg, mit JavaScript-Objekten zu arbeiten.

  • Sprachbrowser


PHP bearbeiten

Rapid PHP bietet spezielle Funktionen für die Bearbeitung von PHP.

PHP-Menü und -Symbolleiste

Mit der PHP-Menü und -Symbolleiste können Sie schnell die allgemeinen PHP-Codefragmente einfügen.

PHP-Snippets bieten ein Auswahlmenü für das Einfügen allgemeiner PHP-Strukturen. Um dieses Menü zu bearbeiten, klicken Sie auf PHP-Snippets bearbeiten.
PHP-Servervariable zeigt eine Liste der Servervariablen. Um ein Element einzufügen, markieren Sie es und klicken auf OK.
PHP Tag fügt PHP-Tags <? ?> ein.
PHP-Block fügt PHP Tags <? und ?> in eine separate Zeile ein und erstellt damit einen mehrzeiligen PHP-Codeblock.
PHP-Ausgabe-Tag fügt ein ASP-Ausgabe-Tag <?= ?> ein.
Datei einfügen fügt die Include-Directive für eine Datei ein.
Require fügt eine Datei-Require-Directive ein.


SSI bearbeiten

Rapid PHP bietet spezielle Funktionen für die Bearbeitung von SSI.

SSI-Menü und -Symbolleiste

Mit der SSI-Menü und -Symbolleiste können Sie schnell die allgemeinen SSI-Tags einfügen.

SSI Snippets bieten ein Auswahlmenü für das Einfügen allgemeiner SSI-Tags. Sie können diese Menü bearbeiten, klicken Sie dafür auf SSI-Snippets bearbeiten.
SSI-Servervariable zeigt eine Liste der Servervariablen. Um ein Element einzufügen, markieren Sie es und klicken auf OK.
Datei einfügen fügt die Include-Tags für eine Datei ein.
Virtuellen Pfad einfügen fügt die virtuellen Include-Tags ein.